Cannot connect to wireless network which has 802.11r (fast roaming) enabled

Really liking the MT3000 so far, but I’ve run into an issue connecting to networks. I operate 4 SSIDs:

  1. Network1 (WPA2 EAP)
  2. Network2 (WPA2/3 PSK) (802.11r enabled)
  3. Network3 (WPA2/3 PSK) (802.11r not enabled)
  4. Network4 (WPA2 PSK) (802.11r not enabled)

When I perform a scan in the gl-inet interface, I am able to see (and join) networks 3 and 4, but not networks 1 and 2. If I enable 802.11r on network 4, it disappears as well. My main wireless setup is a Ubuquiti Unifi setup, with the closest AP to me being a Unifi 6 LR operating on channels 1 and 36. I’ve confirmed that my MT3000 is running US country code and that DFS is enabled.

Device: MT3000
Firmware version: 4.1.2 release 1

Fixed in November 24th firmware

1 Like

I’ll check it out later and confirm!

I can now see the 802.11r network, but can’t join.

I am (still) able to join non-802.11r networks.

Update - this appears to be fixed in the 11/26 firmware version.

1 Like

I may have spoken too soon - reflashed 11/26 because of a DNS issue and getting this again:

Jumping over to Luci, this appears to possibly be the culprit:

ukweli_dev 10 36 XX:XX:XX:XX:XX:XX FT-WPA2PSKWPA3PSK/AES 42 Security Not Supported

I am able to get it connected, but it doesn’t pull an address:


Two networks in question:

  1. ukweli_low (WPA2/WPA3, no 802.11r)
  2. ukweli_dev (WPA2/WPA3, 802.11r enabled).

The networks have different passwords but same security, are being served off of the same Ubiquiti APs.


  1. Full reset of MT3000.
  2. Attempt to join ukweli_dev (the 802.11r network). Repeater interface says “connecting” but never connects. Messing around in luci give what I showed above with invalid security, etc.
  3. Attempt to join ukweli_low (the non-802.11r network). Connection works.
  4. Now attempt to join ukweli_dev again. This time it works.

I haven’t had time to spin up other networks and test whether you can join other 802.11r networks, or if it also may have something to do that these are all being served off the same APs. I’ll have to think about how to set something up with an entirely different network name / AP set.


This appears to be solved in the Dec 5 release.

1 Like