Cannot enable IPv6 on GL-AR750S

Hi!

I want to use a Slate (GL-AR750S) router to split off two local networks; everything on IPv4 works fine as expected (it routes between WAN and LAN just fine), but it refuses to get an IPv6 address/prefix via DHCPv6 on WAN6 and assign it to LAN.

It looks like IPv6 is turned off in various places:

# uci show network.wan6.disabled
network.wan6.disabled='1'
# cat /proc/sys/net/ipv6/conf/eth0.2/disable_ipv6
1

I can enable it, and when I do, link-local (fe80::*) addresses start to appear in ip addr. However, restarting the WAN6 interface still doesn’t work, and it seems that even if I enable it, the router disables it again.

Is there any way to enable IPv6?

Found it! This was set to 0, and setting it to 1 fixed it:

# uci show glipv6
glipv6.globals=globals
glipv6.globals.enabled='1'

This allowed it to get a prefix via DHCPv6. It wasn’t assigning it to LAN, but after I changed the requested prefix from /60 to /64 on both LAN and GUEST (despite being unused), it worked, and everything has IPv6 now.

All fixed!

1 Like