Cannot figure out how to disable isolation for google home devices

Hello there,

So I got a interesting situation currently I have setup a bridge with two DSA vlans 1 and 90 on openwrt 22.02 on the flint release 3 firmware from github.

In openwrt I made two different interfaces:

  • tvnet which shares a 172.18.x.x ip address from vlan 1.
  • zigbee_net which shares 10.33.xx.x ip address from vlan 90.

The zigbee_net interface also gets covered by the wireless network.

So far everything works and every device gets the correct settings, so I can confirm that the vlans just work fine.

Until with one device which is a mi smart clock, when I go through the setup via google home on my phone, I can make the clock make connection to my wireless AP, but then it also wants to find my own device inside the network and that fails even if I connect to the wireless AP myself.

I have tried to enable multicast… And igmp snooping but for some reason I keep getting the warning that the AP is isolated inside the google home app, though inside the bridge settings there is a checkbox called port isolation which is unchecked (default value)

So far I think with the bare configuration on the bridge it should not be isolated unless I’m missing something with 22.02 since DSA is very new in openwrt :yum:

I’m confused why this is, could it be a internal script which turns my access point into a guest wireless access point?

Thanks :grin:

Can you check if “Isolate clients” has been turned on for the wireless interface?

I do not work for and I am not directly associated with GL.iNet


Isolate clients is off, I suspect it might be a script since I have 3 APs on 2.4 ghz it shows on the gl-inet gui as a guest network, I gonna do later another check with iwpriv and check some scripts.

it seems I cannot read out iwpriv I think its due the wlan_ap driver, but its strange that google home keeps saying that it is isolated, I can ping my wireless connected hp printer from lan so it isn’t isolated.