Cannot find the SSID on my GL-USB150 (v3.006)

Hi, I am unable to find the SSID of my USB150 when I go to a different location. I have tried it in multiple locations and the SSID of the router doesn’t show up. I have also tried it in locations with very little wifi devices. It only works when I am at home.

It is configured in repeater mode and connects to my home wifi with no issues. At home I can unplug and plug it back in and the SSID of the router shows up fine.

The only way I could get the router SSID in another location to show up was to go and forget my home network. Once there are no saved networks then I can find the SSID of the router when I go somewhere else.

Can you confirm this bug and have it resolved as it is useless as a travel router right now? This is for v3.006.


We have fixed this bug. Please upgrade to the latest firmware.

Hi, I installed the latest one and I am able to see and connect up to the router’s SSID.

However now I can’t get the Open VPN to connect up. It says it is unable to find the internet and yet I can surf, ping, etc. Seems like a new bug was introduced. Thanks

Could the device access the Internet? It have to access the Internet before starting VPN.

Yes it can access the internet as I can surf and ping websites using the router.

You can look at this post. Bug Reporting Thread For Firmware v3 - #82 by kyson-lok

Hi, I looked at it but it was too complicated for me for what the person did with his script.

This OpenVPN used to work for me on my home network as I don’t have anything special on that network. I also did try it on another network and it still had an issue saying “No Internet” even though I can surf through the router.

Love the size of this USB150 and would love for it to work bug free when I travel. Let me know what else I can try.


Could you try to execute those commands on router? And see if it works.

wget -t 1 -T 3 --user-agent="Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)" -O - 2>/dev/null | grep -m 1 -o '[0-9]\{1,3\}\.[0-9]\{1,3\}\.[0-9]\{1,3\}\.[0-9]\{1,3\}'
wget -t 1 -T 3 --user-agent="Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)" -O - 2>/dev/null | grep -m 1 -o '[0-9]\{1,3\}\.[0-9]\{1,3\}\.[0-9]\{1,3\}\.[0-9]\{1,3\}'

Ran the commands and my public IP comes up for both commands.

Thanks for your feedback, will check it.

Any luck finding a solution for this as I would like to get my OpenVPN working.