Cannot get AR300M to Actually Work

I’m fairly close to pulling my hair out with this little device, I’ve just bought it from Amazon and I just cannot get it to work… I have 3 lights lit up two green and a red one which indicates that the wifi is working? but no ssid is broadcast and I cannot reset it as no matter how long I hold the little button in absolutely nothing happens I have also tried connect via an ethernet cable but no pc in the house will recognise it is connected.

any ideas because at this point it’s quite close to going back to Amazon

Follow this guide and upload the latest firmware for your device, and see if you get farther:

The latest firmware is this when uploading from uboot if you have NAND:

Or this if not:

Hi Thank you for your reply but I’ve just tried to follow the top link and when pressing and holding the reset button the lights just refuse to flash at all and they stay solid :confused:

Hmm @alzhao @kyson-lok could he have a dead unit in that case?

I think so, I’ve just started the return with Amazon I might give another one a go… but not a good start

Sorry to hear that. Please just return and exchange.