Cannot install OpenWRT 21.02.0-rc4 on GL-S1300

I recently purchased an S1300, which comes with the very old OpenWRT Chaos Calmer. I want to upgrade to the latest stock OpenWRT so I can have confidence in the security of the device. When I try to do the upgrade via sysupgrade or the Luci UI it does not work. When the S1300 reboots, it is still running the same Chaos Calmer.

The first thing I tried was to use the procedure recommended by the OpenWRT website:

  • I downloaded openwrt-21.02.0-rc4-ipq40xx-generic-glinet_gl-s1300-squashfs-sysupgrade.bin from the OpenWRT website and copied it to the S1300 using scp. I put it into the /tmp/ directory on the S1300.

  • I logged into the S1300 with ssh and ran this command:

    sysupgrade -v /tmp/openwrt-21.02.0-rc4-ipq40xx-generic-glinet_gl-s1300-squashfs-sysupgrade.bin

I got some output regarding the config being backed up, then the wifi connection dropped. I waited 5 minutes then sshed back into the S1300. It was still running Chaos Calmer. I tried powering it off/on but still it was running Chaos Calmer.

I also tried using the luci web UI to do the upgrade, but again the result was the S1300 still running Chaos Calmer.

I then read in another topic on this forum that suggested installing the s1300-factory-to-openwrt.img firmware upgrade first. So I installed that firmware upgrade (the version for openwrt-19.07.7) via the U-Boot web user interface. Then I tried the sysupgrade procedure again. Still the S1300 is running Chaos Calmer.

Can someone please advise how I can upgrade my S1300 to OpenWRT 21.02.0-rc4?

maybe, now that you have 19.07.7, you can upgrade to 21.02.0-rc4 via u-boot web ?

Many thanks for your reply, Tofan. Upgrading to 21.02.0-rc4 via u-boot web did work and now I have stock OpenWRT on the s1300.

For anyone else who wants to do the upgrade, I followed this procedure exactly and it worked very well:

1 Like

I am having a similar problem with my GL-S1300, but after flashing via uboot, I cannot access the luci page of openWRT, neither there’s the openWRT SSID to config it on now I tried flashing the original firmware, but it’s not working either, I firstly did this procedure: