Cannot join network on iOS devices

Using a GL-AXT1800 on 4.2.1 release
5ghz, tried many different channels, tried wpa2 wpa3-psk, wpa3-sae
Restarting the ios device every time I want to connect fixes the issue, any solutions to this?

We just tested this situation with Apple 14 phone, but did not find this problem. Could you please tell us your ios device model? We will test it

Iphone 14 pro max on ios 16.4.1

Just tested, we were able to connect normally the first time, but when we changed the encryption mode, it failed to connect.We replaced the iphone for testing, and this problem also appeared.But when we used an Android phone and found that it worked, we guessed that the iphone used the previous encryption method when connecting to the saved wifi, so when the encryption method was changed, the original connection would fail.

So what would the solution to this be?

Do you mean after restart ios, the router can connect?

Can you remove the saved ssids on the router and set up again? If does not connect, pls send the log.

After restarting ios I can connect to wifi. Removing ssid did not help. (6.2 KB)

Do you mean your router joins Hotspot of your IOS?

Nono, my phone joins the router… or at least tries to

Is this the log on the router or macos?

Seems from a router. But don’t know why there is a lot of log about odhcpd. The router does not comes with this software. Did you install something?

It was most likely enabled for ipv6, I tried enabling and disabling ipv6 to see if that fixes the issue. It did not :frowning:
Also yes it’s from the router

Do you have any of the privacy services enabled for the netwotk on the iphone 14 Max such as Private WI-Fi address and limit IP address tracking? I am not sure if I had the same problem but when I changed encryption from WPA2 to WPA2/WPA3 my Iphone needed to forget the network and rejoin for it to work. Also noticed that when the Iphone privacy services where enable that I had 15 or so DHCP leases for the same phone. I turned the privacy servers off for the network cleared out the leases.

I already have them off, it still doesn’t work. I’ve tried forgetting the wifi and changing the ssid of it.

Did you install any software in the router, e.g. odhcpd? The router should use dnsmasq to give dhcp addresses.

I suggest that you reset the firmware and check.

After a reset and trying multiple settings the issue still remains, the issue does not happen on 2.4ghz though. The issue only appears on ios

Issue still present, nothing fixes it. Including new ios 16.5 update. I now tried router firmware 4.3.2, still same issue. No traces of issue in router logs as well

Setting the wifi to n/ac/ax seems to have fixed it… very weird issue but it seems to be working now at least

What was the orignal settings?

It was ac/ax before, any reason why this isn‘t fixed yet?