Cannot log into 'Advanced' mode in router portal with the same password


I have freshly set up GL-AR750 for use in my home.

When trying to access the LUCI portal under ‘More Settings → Advanced’, it fails to open with the same password, even though I have read in the online manual that it uses the same password as the main router portal to function.

Is there a character constraint in the password space on this particular portal? Or what could be the cause of it refusing my password?

Thank you!

Can you use the password you set for the fist time?

In some version the root password (luci login) does not change with the default UI password. This should have been fixed.


I tried the following with no success:

  1. Trying a blank password
  2. Trying the same password used for login in the main admin portal
  3. Trying default password of the admin panel for the router

Is there a char constraint that I cannot use? Because my admin password consists of character mix with symbols, lowercase, uppercase, etc. - they work on the main admin portal.

On another note, is there anything else there that cannot be found on the main admin portal? Because if there isn’t, then it won’t matter if i cannot access this part or not. Is there any setting only present in LuCI and not in the admin panel?

Thank you!

It reminds me one thing. When you use special characters it may not work in luci.

We fixed this issues in latest firmware.

I wonder if you can choose a password without special characters.


It can be thats are depend on follow old bug:

The following issue has been ASSIGNED.

GL.iNet - Connecting The World To Secure Wi-Fi

Reported By: Henry_Bruns
Assigned To: kyson-lok

Project: Routers
Issue ID: 135
Category: None
Severity: minor
Priority: normal
Status: feedback
Type: Bug Report

Date Submitted: 2019-02-25 20:38 UTC
Last Modified: 2019-02-26 01:59 UTC

Summary: Security issue: Not possible to set long passwords
or passords with some sorts of caracter on advanced admin menue

  • Set long passwords or password with some sorts of caracters, not possible on
    advanced admin menue. By not working changing of password, you get message like
    “password sucessfull changed” A, the password didnt change !!!
  • Same not realy by changing accepted password on advanced admin menue, can be
    use for change password on normal admin menue. This way change the passord for
    normal admin menue an advanced admin menue.

(0000205) Henry_Bruns (reporter) - 2019-02-25 23:43
GL.iNet - Connecting The World To Secure Wi-Fi

It can be, it need to be configured accepting UTF8 caracters, by gli firmware

(0000211) kyson-lok (administrator) - 2019-02-26 01:59
GL.iNet - Connecting The World To Secure Wi-Fi

Could you please parse the password in here? So I can check it. Please mind the
maximum password length is only 64 characters.

Issue History
Date Modified Username Field Change

2019-02-25 20:38 Henry_Bruns New Issue
2019-02-25 23:43 Henry_Bruns Note Added: 0000205
2019-02-26 01:59 kyson-lok Note Added: 0000211
2019-02-26 01:59 kyson-lok Assigned To => kyson-lok
2019-02-26 01:59 kyson-lok Status new => feedback

General Reserved Characters - these mean things across Windows/Mac/UNIX platforms, so avoid using them for domains/workgroups/hostnames/usernames/passwords/SSID’s

  • ampersand (&)
  • apostrophe (')
  • asterisk (*)
  • at sign (@)
  • backslash ()
  • braces ({})
  • caret (^)
  • colon ( : )
  • comma (,)
  • dollar sign ($)
  • exclamation point (!)
  • greater than sign (>)
  • less than sign (<)
  • number sign (#)
  • parentheses (())
  • percent (%)
  • period (.)
  • question mark (?)
  • quotation mark (")
  • slash mark (/)
  • tilde (~)
  • underscore (_)
  • vertical bar (|)
  • white space (blank)

@sfx2000 Thank you! It appears it was one of these forbidden characters in the password. I’ve changed it and now it works! :clap: :clap: :clap:

And thank you everyone for their involvement to help me.