Cannot reconnect GL-SFT1200 to internet after turning off Wireguard

Scenario: GL-SFT1200 in repeater mode, connected to a different WiFi router, internet works.

Run Wireguard app in GL-SFT1200 with custom .conf, connects to internet without problem. All devices connected to GL-SFT1200 route traffic through Wireguard VPN, as desired.

Stop, disconnect from, Wireguard VPN in GL-SFT1200.

GL-SFT1200 can reconnect to same WiFi router as before, but without internet.

Restart Wireguard app in GL-SFT1200, with same or different .conf’s, and GL-SFT1200 connects to internet, at same WiFi router.

I’ve tried rebooting the GL-SFT1200. Same scenario results. I’ve tried ‘forgetting’ the WiFi router previously connected to, then reconnecting. No internet, except with Wireguard VPN.

Cause? Solution?

Thank you! By the way, the GL-SFT1200 is an excellent device with a lot of granularity and customization in a large featureset. Being a sysadmin who’s new to this device in particular, for personal use, I’m left wondering what is going on. Any and all input is appreciated.

Did you enable “Block non-VPN traffic” maybe?


Great question! It probably was, to prevent DNS leaks, and I forgot to disable it. After the issues reconnecting to internet, I had reset the GL-SFT1200, so I cannot confirm now. But I will now test, with that variable, and report back. Thank you!

That was exactly it! Thank you! Bravo! I now put my hand to my forehead, exclaiming, How could I have missed that!

1 Like