Cannot save VPN config

I have an AXT1800 and I am trying to setup the wireguard client with azirevpn.
I logged into the admin panel → vpn → wireguard client → AzireVPN → enter my azire username and password → clicked “Save Credentials And Get Servers” . I then get the spinning load screen "
Getting, please wait…" and the form clears. I have rebooted and reconnected and tried multiple computers and browsers. I also tried downloading the wireguard config file and uploading it to the admin panel under wireguard. It says “upload successful” and I click apply then nothing happens. It does not save and when I go to the VPN dashboard, no VPN options have been saved. Please help, without the VPN this is a paperweight.

  • Model

GL Technologies, Inc. AXT1800

  • Architecture

ARMv7 Processor rev 4 (v7l)

  • Openwrt Version

OpenWrt 21.02-SNAPSHOT r16399+159-c67509efd7

  • Kernel Version


Hi icistech

You can try to reset the router and re-configure it. Please configure AzireVPN just after WAN connection configuration. If this issue still remains, Please try to describe the details from the reset to the issue occur.

otherwise, Please tell us the firmware version which can be checked in the WEB panel “SYSTEM”–“Upgrade” as below

It was already up to date.
I ended up resetting the firmware to factory default and it works now.