Cannot update firmware

hello, thanks,

router: AR750S-EXT

in all cases, i have tried these images
and i was every careful to check the sha256 for all files.

  1. , i tried uboot and that failed
**Something went wrong during update**
Probably you have chosen wrong file (too big or too small) or you were trying to update ART on device with unknown FLASH type (and size) which is not allowed. 
Please, try again or contact with the author of this modification. 
You can also get more information during update in U-Boot console.
  1. using router’s web interface,
    the router rejects .img files as per image below
    note: the router accepts .tar files

thanks much,

If it accepts tar files, you should be able to use this one in firmware upgrade section in the admin panel:

If not, what error do you see?

Is your current version pre 3.105? If it is then update to 3.105 first and then do your latest version.

For local upgrade in web Admin Panel download and install the tar file from the first link:

I do not know why the img file from the second link does not work in UBoot, as I have not tried it on my GL-AR750S-EXT.

I do not work for and I am not directly associated with GL.iNet

i already made that mistake once, never twice :wink:
but that should not matter with uboot.

basically, i compiled a firmware and was trying to flash it to router.

So did you finally flash?

uboot only accept .img
Openwrt only accept .tar

in the end, i used .tar