Cannot upload OpenVPN Config File

I’ve a GL-AR300M which I want to connect to my exisitng VPN Server however when I try to upload a config file it remains on the uploading status forever.

I have tried resetting to factory settings and tried via the app which shows ‘response error please check your network’, the file is only 5kb and works in a teltonika router and via windows client.
Thank you.

Whats the format *.conf . You should also be able to drop in a browser window and see the context of the file usually has # symbols on left side the server Ips and keys. SurfShark for instance has different configuration files for the router then for the desktop/mobile. Not sure why it did not kick the file out as not being usable.

Its an opvn file.

dev tun
proto udp
cipher AES-256-GCM
remote 1194
verify-x509-name "O=OpenVPN, CN=server"
mute 20




key-direction 1

-----BEGIN OpenVPN Static key V1-----

-----END OpenVPN Static key V1-----




I have also tried to upload via ssh but the router password will not work for root user.
and ive tried reinstalling the firmware via uboot and that doesnt seem to work either, have a feeling this device is compromised or faulty.

I just want to make sure YOU REMOVED THE SECURITY CERTIFICATE, STATIC KEY AND PRIVATE KEY for privacy and security reasons correct? Cause if you didn’t theirs you problem.

It looks good

What does the sys log show when it happens?
I do not personal have a GL-AR300M

managed to get uboot to work, i can now get into the command line, syslog say nothing when i try to upload a file.
tried to upload the file at 16:13… here are the last two entries

Wed Sep 21 04:12:25 2022 authpriv.notice dropbear[16665]: Password auth succeeded for 'root' from
Wed Sep 21 04:16:38 2022 user.debug : [  233] gl-sdk>> Cgi Get a signal -- SIGSEGV

Where does the config file go can i upload it via ssh and then connect?
i tried running openvpn commands from the command line but no luck.

Tried with a new client config and it worked, only difference is the private key, maybe theres something in the key that is causing an issue. problem i have now is it seems to route all traffic even though the config states route not `route gateway, I only want traffic to that range through the VPN all other traffic can goto the WAN.

1 Like