Cannot use repeater function for a cruise wifi

Unfortunately I do not have a cable with me.

Well this states cloning the MAC solves all issues, but that is not working for me. Of course I have a lot less time and budget for this little project than the whole cruiseline company, but the solution must be something stupidly simple…

It probably is but it seems I’m either too stupid or simple to further assist. I’ll bow out here.

Thanks for your help dude! Maybe I should really forget it and enjoy the holiday :slight_smile:


Enjoy your time on the boat.

Here is my thought::

The MAC Address of the access point of the boat is Aruba enterprise.

Companies are using software like Clearpass that can block mac address switching. It’s becoming harder to use portable routers.

The cloned MAC address needs to also match the IP address as well, try cloning both IP and MAC. BUT that still might not work as it also checks other items like OS, etc of the device. So if you have a windows machine, then the same MAC is used for a Linux machine, it won’t work as the profile is a mismatch.

So please enjoy your trip instead :slight_smile:

1 Like

I was recently camping on a farm and faced a similar problem with trying to use the Beryl AX as a repeater with no amount of MAC cloning, DNS changes…etc working at all and I could not believe that their system would have been sophisticated enough to block the router in the way you have described. Furthermore, trying a different make worked straight away and with no fuss at all leading me to the conclusion that there is undoubtedly an inherent issue with the GL.iNET’s abilities to repeat WiFi and/or deal with captive portal.

Yep; I may well be quite simple (note to self: read the damn logs!). Perhaps it’s a matter of disabling (ideally just adjusting the timeouts of) Multi-WAN tracking as the Repeater appears to handshake to the WLWAN but then drops connectivity some 13 seconds later:

Sun Apr 9 13:39:05 2023 daemon.notice hostapd: EAPOL-4WAY-HS-COMPLETED 60:57:18:c0:66:79
Sun Apr 9 13:39:08 2023 dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 60:57:18:c0:66:79
Sun Apr 9 13:39:08 2023 dnsmasq-dhcp[1]: DHCPACK(br-lan) 60:57:18:c0:66:79 LAPTOP-NAME-REDACTED
Sun Apr 9 13:39:21 2023 user.notice mwan3[9210]: Execute ifdown event on interface wwan (wlan-sta0)

GL GUI → Network → Multi-WAN → Interface Status Tracking Method → Repeater → [gear icon(s)]

(I swear I’m bowing out now!)

What was the other make?

Good find, I skimmed the logs myself. I didn’t notice the mwan3. I don’t think that multi wan is enabled by default out of the box, is it?

It is enabled OOTB on my Slate AX, f/w 4.2.3; I only changed the tracking IPs. I couldn’t imagine it not being also active w/ Repeater mode. I’ve had one or two strange little ‘gotcha’s’ that seem to be related to multi-hop latency when different GL devices are behind other routers in my LAN.

ps -w | grep mwan
 4551 root      1388 S    /bin/sh /usr/sbin/mwan3rtmon
22157 root      1308 S    /bin/sh /usr/sbin/mwan3track wan eth0 online

Tried that and this time the browser got redirected to the captive portal, then timed out. That does not happen when connecting the laptop directly, after the very first time registering the laptop every next time it just connects without the captive page. So I am pretty sure MAC spoofing is not enough and they are using whatever fingerprinting abilities of the Aruba devices. I will probably drop the attempts now, it obviously requires more than a cheap device and unprepared user to get in. Thanks for all the help anyway!


It’s been getting difficult to have hotspot at hotels, cruise ships, planes etc. Companies are catching on and they are losing revenue if they don’t do something.

Bought this one at the time and worked straight away:

I would have thought that these sites would also block TP-LINK routers first as they are undoubtedly much more prevalent and popular than GL.iNET as travel routers.

Have you come across or tried this?:

or @Messagedj solution here:


Haha, that manual IP trick did work! I guess you cannot go stupider and simpler than that! :slight_smile: Thanks everyone for your help, this is a great community!

Added: One thing worth mentioning, I had to reboot the device and set it to use a 5Ghz network manually, it did not work with automatic 2.4Ghz.


Awesome! Great to hear

Glad that you have cracked it. Interestingly, I have had to once set mine to 2.4GHz manually (from auto) before it would work. I guess one will have to book an extra day of holiday from now on to account for the time lost fixing these things!

Registered an account just to say thank you!!! The 5GHz band selection was the key that got it working for me, thanks for the tip!

Edit - I actually tried both 2.4GHz and 5Ghz and they both worked - I think the trick is you need to lock down to one of the bandwidth, might be useful to some people since 2.4 has better penetration power which might be helpful if your room isn’t too close to the wifi router on the ship.


I am currently in a MSC cruise and I’ve tried everything mentioned but I still can’t make it work.

I have logged in to the internet using my phone without the random MAC address option activated. I then proceed to the travel router and have done the following:

  • Clone the Mac Address assuring that it is not the random one
  • Statically set the IP address of the router, gateway and DNS, equal to the phone setup
  • Disable MultiWan setting on the repeater function
  • Even tried changing the outgoing TTL to 64, 65 and 68 using an iptable command I found in another thread

I left the router with these settings connected during the night and received some notifications. I was even able to update the router firmware to the latest 4.5.x using the online function while connected to the cruise network but still couldn’t access the internet or captive portal on the phone. I am now trying the beta 4.6.0 but the problem persists…

Can you think of any thing to solve this? I am on a gran voyage cruise so I have time to try different settings :slight_smile:


Are you also using the Beryl AX? These devices are absolutely notorius for their problems and issues when it comes to being used as the travel routers that they are advertised to be. After many years and countless reports of these difficulties, finally some indication from the CEO himself of the significant issue but unsure if a solution might finally be on the horizon:

I’m using the GL-A1300