Mac Clone on but still can’t connect

I use my Ar150 a lot at hotels for WireGuard vpn. I just connect with my phone to the captive portal and then clone the MAC address with the router and have all devices go through it.

Today, though, it’s not working. I’ve double checked the MAC address is cloned (and not the “private” MAC address phones default to these days). I can connected fine with my phone, but then when I disconnect from hotel wifi and switch to the router, I can’t reach the outside world. Any idea what could be wrong? Can I set the IP address of the router manually? (I mean the IP address of the router as a client to the hotel network.). I’m using the “Repeater (STA)” mode that’s in the home page of the router. Thanks.

Found the advanced settings where I could manually set the IP address. Only when I do that does it work.

2 Likes

So the repeater connected but the router cannot get IP address.

When you manually set the IP it works?

The hotel had a pay-per-device setup. I used my iPhone as the device I paid for to connect to the portal. The only way I could connect behind the gl.inet router was to go into the advanced settings and set the router’s client IP address to Static and set it as the same IP address given to my phone (the device that connected originally to the network) via DHCP when I originally connected the phone. If the router just got it’s own DHCP IP address, I couldn’t connected to the internet even though the router had the cloned MAC address of the phone. The router was NOT given the same IP address after I disconnected my phone from hotel wifi and connected router to hotel wifi.

It worked then, but after a short while, the router would snap back to getting an IP address from DHCP and I would have to back and set it as static again and set the same IP add that the phone originally got. If I opened a wireguard tunnel, it seemed to keep the router set to static IP address for a lot longer (over night one night), but still would reset at some point.

Hotels and public wifi usually assign DHCP IP addresses with short lease times of 24 hours or less.
The part that puzzles me is why your router switched from the static IP you had set over to DHCP.

I do not work for and I do not have formal association with GL.iNet

It was just annoying that the router kept resetting to DHCP instead of keeping the static address. At least at worked!