Cannot use ssh or web gui through Goodcloud but Site-to-site works

I have a GL-AR300M that will no longer connect via Goodcloud either via ssh or the web gui. When trying to connect via Goodcloud ssh, the ssh terminal opens but immediately gives an error that says the device is offline. After trying this several times, Goodcloud will show the device as offline.

However – I have this device set up in a site-to-site network. I can connect to the “offline” device through another machine on the site-to-site network. The Goodcloud site-to-site GUI shows the device connected to the site-to-site network, and refreshes the data transfer numbers – but still shows “Status: Offline”

For this issue, can you send email to support at with the router’s ID and mac address?

Do you have vpn active other than S2S?

@bhphosting Please make sure that the email you sent the request to tech support is the same as the registered Goodcloud account too.

I received an insecure email from support asking for my account login and password. No thanks.

Support should never ask for password. Let me check with support.

This issue is still happening. Support email stopped after I refused to provide my login password.

If I look into “View Logs” under Cloud Management, I see a bunch of utils_NLB failed errors.

init set log level = 6

mqtt start!

url =

utils_NLB failed!

url =

utils_NLB failed!

[the error repeats every 8-9 seconds]

How about removing this device from your s2s network first, and check the device if still show offline in Goodcloud?

Your device failed to connect to cloud for some reason.

Tried that. It wasn’t set up to be p2p when this problem started, I actually added it to p2p to see if it would reset something.

Have you ever try with other server in Goodcloud? If you still get the same error, please pm the wan mac address of your device to me.