Canon printer will not connect to Cirrus GL-AP1300

Hi Guys, I’m struggling to connect a
Canon ImageClass multi-function laser printer MF645Cx to a
Cirrus GL-AP1300LTE.

The printer can find the 2.4GHz Wifi signal but after entering the pw it will never connect to it.

I have tested many other 2.4GHz Wifi (including other GL-i devices) with the same Wifi settings and the printer will connect.

I have the pw correct; I’ve typed it dozens of times now.
The SSID has no special characters or spaces. I’ve tried various modes and bandwidths;
WAP2 and WPA. Still the Canon will not connect to the AP1300.
No other client has trouble. (This printer does not have a 5GHz radio.)

Any suggestions?

Try to switch channel to another

thanks for the idea La3y.

I changed from Auto and tried several different specified channels.
The printer still fails to connect.

During a support call with Canon they asked if I was running a WiFi Mesh.
I replied No.

On thinking about this, the Cirrus router is a Mesh router.
Is it running a mesh service even though there are no other devices to mesh with?

It does not have mesh enabled by default.

Maybe just some wifi parameters.

Try wpa-mixed

Also disable wmm if enabeld. In the UI you may have this but if you ssh to the router and remove

Mixed WPA solved it. (I thought I had tried this. D’oh!)
Thanks for the suggestion Alzhao

1 Like