Can't configure MT1300 Beryl over Wifi?

I want to use a GL-MT1300 Beryl as a backup for my main BT Home internet connection by using it as a WiFi repeater to an EE Mifi. I will need to access the internet via the Ethernet port on the MT1300 because my ancient desktop does not have WiFi.

I am having severe problems configuring the MT1300 using my mobile phone over WiFi.

  1. The MT1300 WiFi connection frequently drops breaking the connection to my phone, which silently reverts to the main BT Home internet connection.
  2. The EE Mifi’s Wifi network does not usually appear in the list of available networks on the MT1300 although it is strong and reliable on all my other devices. Occasionally it DOES appear but when I try and enter a password the WiFi connection to the phone drops.

I have tried the following

  1. I have upgraded the firmware to 3.201.
  2. I have reset the MT1300 to factory settings.
  3. I have installed Luci although I am not familiar with DD-WRT.

It’s VERY frustrating. Can anyone advise before I send the unit back to Amazon? Are there any tweaks to make the unit reliable?

many thanks

I think what you are experiencing might just be the wifi reconfiguring itself as you make changes.

  1. If your desktop is connected via ethernet to the Beryl, you might try configuring the Beryl from the desktop.
  2. When the wifi of the Beryl reconfigures itself (as it would do if you are connecting to the ee), the wifi signal stops for a time. Your phone sees that, and then connects to whatever else it finds. You should “forget” that network, or set it to not autoconnect, so that the phone doesn’t do that, and waits for the Beryl to come up again. After you are done setting up the Beryl you can revert those settings.

Thank you for your advice.

I have tried configuring via Ethernet and it still won’t connect to the Mifi. A window pops up with “wpa_supplicant error”. This is annoying because all other devices seamlessly connect to the Mifi.

Is there anything else I can try?

many thanks

  1. You are making the ethernet connection to the LAN port, not the WAN port, yes?
  2. Under More Settings|Network Mode, this is set to “Router”, yes?
  3. You are trying to connect to the EE Mifi under Internet|Repeater|Scan, yes?
  4. You can still try with the phone, temporarily disabling the other networks. I have no difficulty connecting wirelessly to my Beryl and then setting up the connection to another wifi network. Quite reliable for me.

PS: The Beryl and luci is OpenWRT, not DD-WRT

Yes, yes and yes.

I can connect the Beryl to the BT Home Wifi but not the EE Mifi. All my other devices will easily connect to either network. I was hoping there was some config setting that I could try.

This feels like a design fault. I’m sending it back and getting a TP-Link router.

Many thanks for your help.

Last idea. Does the EE broadcast on both 2.4 and 5? Maybe the Beryl is scanning on the wrong band?

Beryl can see the WiFi network created by the Mifi but cannot log on to it. The error comes after I enter the Wifi key.

The unit has gone back to Amazon now. It’s a shame because it had a great feature set. However, out of the box it is not usable.