Can't Connect MT3000 to Hotspot via Ethernet

First, here’s the TL;DR …

I’m setting up a shiny new Beryl AX, model GL-MT3000. Trying to use my 5G Hotspot as the Beryl’s WAN connection via Ethernet. It works perfectly if connected via WiFi, but not if I try to connect via Ethernet.

I know that the Beryl’s Ethernet WAN is working. I know the Hotspot’s Ethernet LAN is working. But when I connect the two together, hoping to use the Hotspot’s Internet connection as the Beryl’s WAN, the Beryl get’s stuck on “Connecting …”.

I’m wondering …

  1. Is there some feature or function on the Hotspot that I need to make sure is enabled so that the Beryl knows it’s connected to a working Ethernet?

  2. How can I troubleshoot the connection?

And here are the details:

I’m trying to connect a new Beryl AX (GL-MT3000) to a 5G Hotspot via the Ethernet WAN interface. The 5G Hotspot is specifically an Inseego MiFi X Pro 5G. It has exactly one Ethernet port, which serves on that unit as a LAN port. In what follows I’ll call this unit “the Hotspot”.

There’s another router involved in my testing. It’s specifically a WiFi Ranger GoAC. It’s your typical router, with a single WAN port and multiple LAN ports. In what follows I’ll call this one “the Home Router.”

So, here’s what’s happening …

  1. If I connect the WAN port on the Beryl to any LAN port on the Home Router, it works perfectly and I surf the Home Router’s Internet connection via the Beryl. This tells me that the Beryl’s Ethernet is enabled and working.

  2. If I connect the WAN port on the Home Router to the Ethernet port on the Hotspot, it also works perfectly, and I surf the Hotspot’s Internet connection via the Home Router. This tells me that the Hotspot’s Ethernet port is enabled and working.

  3. BUT … If I I connect the “2.5G WAN” port on the Beryl to the Ethernet port on the Hotspot, the Beryl recognizes that there’s an Ethernet cable inserted, but it won’t connect. Both the iOS app and the Web admin page just show “Connecting”, literally for hours. I’ve let it go for as long as 8 hours and it still showed “Connecting”.

More info, for what it’s worth:

  1. The Beryl connects perfectly to the Hotspot via WiFi, it just won’t connect via Ethernet.

  2. I’ve tried disabling detection of Internet connection on the Multi-WAN page of the Beryl’s Admin app. It still just shows “Connecting”.

  3. I’ve updated the Beryl’s firmware to the latest.

  4. I’ve rebooted both devices. No change.

  5. I’ve tried a different Ethernet cable. No change.

  6. A piece of info that may or may not be helpful. While this is happening, in the log I see long strings of “kern.err kernel” that say “7981@C00L1.RPM_PeerBeaconReqSanity() 339: unknown Eid: 51”. I have no clue if they’re related to this.

Thanks in advance.

Replying to my own brand new post.

First, an apology to our wonderful friends in Tech Support. They sent me a promising solution over a week ago, and my email system didn’t show it to me. (It’s always the system’s fault, of course, never mine.) I just now saw their email.

Turns out that there’s an incompatibility, apparently hardware/firmware, between these two pieces of equipment. Tech Support suggested putting a network switch between them.

IT WORKED!!!

Thanks, and once again apologies, to the TS folks, who had my solution and responded so quickly.

Hi ecp:

What is the model of this Hotspot?

Hi, lizh,

The hotspot is an Inseego MiFi X Pro 5G.

Didn’t find a model number, but here’s a link to T-Mobile’s description:

https://www.t-mobile.com/hotspot-iot-connected-devices/inseego-mifi-x-pro-5g

I replied you on the ticket and glad to know your issue is solved.

inseego 5G cellular network hotspot

I suspect the model number is M3000. I’m trying to connect my new Baryl to the same hotspot and ran into the same problem. I’ve been pulling my hair out for 2 hours. So glad I found this post.