Can't connect via PPPoE

Hello, I have a new ISP and trying to connect onver PPPoE without success.
Here are some isntructions of my ISP: Parametri connessione Internet - Tiscali Assistenza
I tried putting the username and passwd they gave me, on internet> cable but it shows “dialing, pelase wait” for hours and nothing happens.

What’s your device model?

AP1300 with 3.217 sorry, the spitz I have stock firmware.

You are not using gl firmware ?

I am trying with the spitz 750, I thought I was answering on openwrt forum on the other tab here…my bad…this post is about my AP1300 with GL 3.217 firmware

Does your isp use vlan id ?

Not sure, I was seeing this page when trying to connect, it’s in italian but protocolls and letters must be the same: Parametri connessione Internet - Tiscali Assistenza

How is your AP1300 connected to the internet ? Do you have pppoe valid subscription with your isp?

I have a 4G sim on it, but I also connected via HCTP with the cable of connect to my ISP router.

what is hctp?


And what type of connection does you isp router use? ADSL?

HTCP, my ISP uses FTTH, they deliver the fiber to a small box and that box has an ethernet cable to connect to my router. The ISP provides a fritz box 5530 as router, if that’s relevant

Got it thanks.

Disable the 4g connection, then try to connect using pppoe.

Does the fritz Wok without issues? Can you check the pppoe settings from there ?

I am suspecting that MAC address of the fritz is authorized to connect to your isp ! So you might need to set your AP1300 to the Mac of the fritz.

It does not work, just tried.

Yes the fritz, works, let me try to setup the ap1300 with the fritz mac address
here’s the error it shows:

 Plugin loaded.
RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
pppd 2.4.7 started by root, uid 0
Plugin loaded.
RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
pppd 2.4.7 started by root, uid 0 

To set the Mac,

Login to LuCi
Go to interfaces
edit the wan interface and enter the Mac there

Always keep testing while 4g is disconnected otherwise the pppoe authentication will be routed through 4g connection instead of the wan port

Where exactly in WAN?

Login to LuCi and you can find it under devices or interface - I don’t recall which one.

It’s called MAC override.

Does not work, but it does not makes much sense(they would not block to mac address), here they offer the freedom to use any router you want and also provide a documentation on the ISP website.

Hi, You have ti use vlanid 835 for the wan, you can set it in luci then set ppoe with credential that you have by ISP.