Can't figure out wired connection with Opal

Hi everyone,

I’ve recently acquired an Opal which I updated to 4.3.7.
My setup prior to this, was a ZTE H288A (ISP provided) with DCHP deactivated and a RPi with PiHole and WireGuard installed, playing the role of DNS and DCHP server. WireGuard was used only for connecting to the RPi when away from home.
I connected the Opal WAN port to a LAN port in the ZTE, I enabled Drop-in Gateway and setup PiHoles DCHP Router Address to mach that of Opals. All my Ethernet devices are connected to the ZTE.
My problem is that although Wi-Fi connection is working just fine, it doesn’t happen the same with Ethernet. In order for my Ethernet devices to connect to the Internet, I have to set up static IPs with the ZTE as default gateway and the RPi as DNS. I can’t set up DHCP no matter what.
What am I doing wrong here?

Thank you in advance

Did you mean Pi-hole’s DHCP Server (not a Router) instead?

Instead of setting your PiHoles address to match the Opals, set DHCP Gateway under NETWORK → LAN to your PiHoles.

Exactly that is what I mean. That is what I’ve got as a message in order for the Drop-in Gateway to work.

In Opal under Network → LAN I see the default settings used for the private and guest network in Wi-fi

In the drop-in settings, do not inser the PiHoles IP if it is not installed on your main router. These settings are only for the Main upstream router.

I think the PiHoles DNS server IP should be set in your 2nd screenshot: DHCP Gateway.

1 Like

Thank you for the time and effort!


In the Drop-in Gateway and DNS Server I’ve put in the ZTEs IP (ISP main Router) . Now, when I set up DHCP in an Ethernet device, ipconfig shows the Opals IP as DHCP and DNS. The given IP is from the from PiHole pool range. I tried to set PiHoles IP as DHCP Gateway in LAN-Private Network (2nd screenshot), as per your suggestion, but I’ve lost internet connectivity. Since it is optional, I’ve deleted it.

Now, I have internet connection in my Ethernet devices using DHCP, but I have serious doubts about the setup being correct. I’m puzzled by the settings in my 2nd screenshot, they seem to have an effect only on the Wi-fi connected devices (my phone sees as router and acquires an IP from the pool. So, there is the PiHole DHCP server for Ethernet and Opal DCHP server for Wi-fi?

One thing more that bothers me is, that it seem like having Drop-in activated, renders VPN unusable vor the Ethernet clients. I guess I have to find a way to set things up without using Drop-in.

That’s what I was about to suggest to you! In fact the drop in feature is not flexible to all configuration scenarios.

I’ve realized that! But I see that it might not be possible from the Admin Panel. And if I need to dive into Luci, I’m afraid it’s gonna be a big mess :smile:

don’t be afraid! Tinker around till you got it!

I’d normally would, but it’s not easy when you know that your family will come after you and will lynch you if there’s no internet at home for 1 minute! :grin:

Then you can use the drop-in gateway feature but with installing PiHole on the gl device and use it instead of dnsmasq. Or just use ADGuard if you don’t really need the functionality of PiHole.

Thank you for the suggestions.

From what I read, Adguard is not compatible with Opal, and after searching abit I found several mentions in Forums regarding installing PiHole in OpenWRT or DD-WRT but none successful.
Having a RPi PiHole server isn’t bothering me. The reason I want to ditch Drop-in Gateway is this:


I’d love to be able to use VPN also with my Ethernet Clients not only with Wi-fi.
But this is a subject for a new topic, I guess! Until now, I wasn’t able to find a way to do this.

Thank you again for your time a patience SpitzAX3000 :slight_smile:

1 Like

I’m running AGH on my Opal - where did you read it’s incompatible?
You can’t have that much block lists, indeed. But it’s working.

Hi admon!

In AdGuards Home Page:


Opal is not supported. It’s not “incompatible” per se but it gives the “do not install” vibe.