Can't get WireGuard Client To Connect

I would like my IP address/location to remain the same while I’m traveling. I have set up the Opal as the WireGuard Server, but I can’t seem to get the WireGuard client to connect on the Slate plus. I have Verizon and have port forwarding set to both TCP and UDP, however I have tried using just one or the other and I still can’t connect. Would the issue be with my configuration? I’m stuck and not sure what to do here.

This is my configuration for the Wireguard Client on the Slate plus:

Address =
ListenPort = 54413
PrivateKey = *************

AllowedIPs =, ::/0
Endpoint = *****
PersistentKeepalive = 25
PublicKey = ***************

The Log just gives me: “Reloading firewall due to ifdown of wg client” “wg client is setting up now”
and then “IFNAME=wgclient ACTION=REKEY-TIMEOUT” forever

I assume this is your Slate config. What is the Opal config? What port number did you forward on your Verizon router?

Is your Slate on a different WAN, like at a coffee shop or a friends house, when you tried to connect? You should only need to port forward UDP for Wireguard.

Hi! Yes, both are on the same network. I’m using 51820 as the port.This is the config for the Opal:


Address =
ListenPort = 54413
PrivateKey = **********

AllowedIPs =,::/0
Endpoint = *********:51820
PersistentKeepalive = 25
PublicKey = **************

Is the Opal configured as a Wireguard server? That looks like a client config, and it is listening on port 53205.

Do you have ssh access into the Opal. If so, what does the command


output. Be sure to hide the key values before posting.

Have you look through the guide from GL inet on setting up Wireguard?

3.x firmware

4.x firmware

To manager your router, you should learn how to use ssh. On Windows 10 or 11 if you bring up a command shell, you should be able to access your router with the command:

ssh root@

and use the same password as your Web login.

To quit, just enter


I initially followed this tutorial: Use Home IP Address While Traveling with GL.iNet AX Slate, Opal, and WireGuard® VPN - YouTube

But, I may just start all over… I’ve made so many changes trying to troubleshoot the connection issue that I feel lost.

I would start clean, using the GL iNet instructions.

I use a Slate (the very good original Slate, not the newer, bigger ones with 4.x code) as my travel router, running Wireguard, OpenVPN and SoftEther client VPN protocols. I use it daily, and it works great.

In the past I have setup a GL iNet N300 router running 3.x firmware using GL iNet’s GUI as my Wireguard server, using their instructions for the 3.x firmware. It ran fine, but I did not like being limited to 1 protocol on 1 port.

I now use an AR-300M as my VPN server located at a family member’s home in the US, that I have highly customized to run Wireguard, OpenVPN and SoftEther on multiple ports, so it is much harder to get locked out of a remote sites. Its been working great for over 2 years now, and I use it daily, as I travel the world. Having the SoftEther server packages on it really helps out, as there are times it is the only protocol that is not blocked from some of the places I have visited. Too bad GL iNet does not support SoftEther as client or server out of the box.

Yes, I have one of the newer Slates. That’s very smart. Do you not notice any difference in speed/latency when you’re using the other VPNs?

And thank you for the additional information. I was able to connect the client via AzireVPN. However, I originally wanted to have it so that my location would show as wherever my server is located, and that isn’t the case with this setup.

Wireguard is the fastest, OpenVPN the slowest, and SoftEther in the middle on speed.