Can't install Easytether on a GL-MT300N-V2

I’m trying to install easytether-usb-openssl_0.8.7-1_ramips_24kec.ipk on a GL-MT300N-V2 from the 15.05.1/mt7628 folder that I downloaded from the Easytether website but I get the errors:

  • pkg_hash_fetch_best_installation_candidate: Packages for easytether-usb-openssl found, but incompatible with the architectures configured

  • opkg_install_cmd: Cannot install package easytether-usb-openssl.

in Putty.

Any help would be appreciated.

MT300N-V2 uses LEDE and you need to find the package for LEDE 1701

You cannot install openwrt packages.

How I got EasyTether working on the GL.iNet GL-MT300N-V2:

  • Installed clean firmware: http://www.gl-inet.com/firmware/mt300n-v2/clean/
  • Download LEDE IPKs:
    • Path: https://www.gl-inet.com/lede/ramips/2.264/packages/base/
    • Path: https://www.gl-inet.com/lede/ramips/2.264/packages/mt7628/
    • kmod-tun_4.4.93-1_mipsel_24kc.ipk
    • zlib_1.2.11-1_mipsel_24kc.ipk
    • libopenssl_1.0.2k-1_mipsel_24kc.ipk
    • easytether-usb-openssl_0.8.7-1_mipsel_24kc.ipk
    • kmod-mii_4.4.93-1_mipsel_24kc.ipk
    • kmod-usb-net_4.4.93-1_mipsel_24kc.ipk
    • kmod-usb-net-cdc-ether_4.4.93-1_mipsel_24kc.ipk
    • kmod-usb-net-rndis_4.4.93-1_mipsel_24kc.ipk
  • Copy to router with WinSCP
  • SSH to router and install: opkg install <ipk file name>
  • Reboot router
  • Run EasyTether USB setup wizard on phone, enable USB, and connect to router
  • Login to Router, then Network > Interfaces > Add New Interface
  • Name it, set protocol to DHCP Client mode, and select > Ethernet Adapter: "tap-easytether"
  • Assign the interface to the WAN firewall zone
Done! I just did this with my LG G5 on Sprint in Houston and hit 32Mbps down through the Ethernet port.

Was able to install Easytether following the instructions in this link https://docs.gl-inet.com/en/2/app/tether/

The driver pick up was a little confusing…So for the next person trying this please use LEDE for MTN300N-V2. For me it was the latest one and only one easytether-usb-openssl_0.8.9-4_lede-17.01.6.
Then in here please go the this folder to find the right driver. Then follow the rest of the instructions.
the ipk driver folder is in \easytether-usb-openssl_0.8.9-4_lede-17.01.6\17.01.6\ramips\mt7628 file name: easytether-usb-openssl_0.8.9-4_mipsel_24kc.ipk