Can't install rsyslog

I’m chasing an issue with dropped connections and connections that do not automatically reconnect on meshed B1300s. These started immediately following upgrade to firmware to 3.105 downloaded from here. I manually updated both routers from Luci. I have logs from client devices being stored on a computer and was about to include the logs from the B1300s when I hit this:

opkg update && opkg install rsyslog
... (snip)
Updated list of available packages in /var/opkg-lists/glinet_glinet
Unknown package 'rsyslog'.
Collected errors:
 * opkg_install_cmd: Cannot install package rsyslog.

I know this has worked in the past. Was this left out of the repository by accident?

@alzhao @hansome please help!

I tried to roll my own build using the image builder adding “rsyslog” and received the following messages:

collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for athdiag:
 * 	qca-wifi * 
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-qca-wifi-unified-profile:
 * 	iproute2 * 
 * opkg_install_cmd: Cannot install package rsyslog.
Makefile:139: recipe for target 'package_install' failed
make[2]: *** [package_install] Error 255
make[2]: Leaving directory '/media/mike/gli/gl_imagebuilder/imagebuilder/3.1/openwrt-imagebuilder-ipq806x-QSDK_Premium_3.1'
Makefile:107: recipe for target '_call_image' failed
make[1]: *** [_call_image] Error 2
make[1]: Leaving directory '/media/mike/gli/gl_imagebuilder/imagebuilder/3.1/openwrt-imagebuilder-ipq806x-QSDK_Premium_3.1'
Makefile:199: recipe for target 'image' failed
make: *** [image] Error 2
Failed to build QSDK_Premium...

You should also be using the SDK from here:

Follow all the steps and you shouldn’t have any issues.

Can you search the repo from the UI and check if there are some packages like this?

If not then need to compile .

@alzhao rsyslog is not in the gli repository. I’m guessing it was removed at some point. I do find it in the Openwrt git where I’d expect it.

Apparently logd is also able to make the connection and logs are being copied. I didn’t realize that logd could talk to rsyslog. LOL

1 Like