I can't recommend 'IoT'.
When I buy IoT devices I look out it is compatible for local setups. A good source it Home Assistant.
I try to focus on Shelly, Tapo, Miele, ... depends on what I want to archive.
I can't recommend 'IoT'.
When I buy IoT devices I look out it is compatible for local setups. A good source it Home Assistant.
I try to focus on Shelly, Tapo, Miele, ... depends on what I want to archive.
Thank you again for you precious help and clear step by step guide.
Those are the requested information:
For network:
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd-----/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth1'
option macaddr '-------'
config device
option name 'eth1'
option macaddr '-------'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.8.1'
option netmask '255.255.255.0'
option ip6assign '64'
option isolate '0'
option ip6hint '0000'
option ip6ifaceid '::1'
option ip6class 'local'
config device
option name 'eth0'
option macaddr '-------'
config interface 'wan'
option device 'eth0'
option proto 'dhcp'
option force_link '0'
option ipv6 '1'
option classlessroute '0'
option metric '10'
config interface 'wan6'
option proto 'dhcpv6'
option device '@wan'
option disabled '0'
config interface 'tethering6'
option device '@tethering'
option proto 'dhcpv6'
option disabled '0'
config interface 'wwan6'
option device '@wwan'
option proto 'dhcpv6'
option disabled '0'
config interface 'guest'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.9.1'
option netmask '255.255.255.0'
option ip6assign '64'
option multicast_querier '1'
option igmp_snooping '0'
option isolate '0'
option bridge_empty '1'
option disabled '1'
option ip6prefix 'fd-------/48'
option ip6hint '0001'
option ip6ifaceid '::1'
option ip6class 'guest'
config interface 'modem_1_1_2_6'
option proto 'dhcpv6'
option disabled '0'
option device '@modem_1_1_2'
config rule 'policy_direct_rt'
option lookup 'main'
option suppress_prefixlength '0'
option priority '1100'
config rule 'policy_default_rt_vpn'
option mark '0x8000/0xc000'
option lookup '8000'
option priority '1101'
option invert '1'
config rule6 'policy_direct_rt6'
option lookup 'main'
option suppress_prefixlength '0'
option priority '1100'
config rule6 'policy_default_rt_vpn6'
option mark '0x8000/0xc000'
option lookup '8000'
option priority '1101'
option invert '1'
config rule 'policy_default_rt_vpn_ts'
option lookup 'main'
option priority '1099'
option mark '0x80000/0xc0000'
option invert '0'
config interface 'wwan'
option proto 'dhcp'
option classlessroute '0'
option hostname '*'
option mtu '1500'
For wireless:
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/soc/18000000.wifi'
option band '2g'
option channel '1'
option htmode 'HE20'
option disabled '0'
option country 'CN'
option random_bssid '1'
option legacy_rates '0'
option hwmode '11g'
option txpower '30'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'GL-MT3000-46f'
option encryption 'psk2'
option macaddr '----------'
option key '----------'
option wds '1'
option isolate '0'
option ifname 'wlan0'
option ieee80211k '1'
option bss_transition '1'
option hidden '0'
config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/soc/18000000.wifi+1'
option band '5g'
option channel 'auto'
option htmode 'HE80'
option disabled '0'
option country 'CN'
option random_bssid '0'
option channels '36,40,44,48,149,153,157,161'
option legacy_rates '0'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'GL-MT3000-46f-5G'
option encryption 'psk2'
option key '----------'
option wds '1'
option isolate '0'
option ifname 'wlan1'
option ieee80211k '1'
option bss_transition '1'
option disabled '0'
config wifi-iface 'guest2g'
option device 'radio0'
option network 'guest'
option mode 'ap'
option ifname 'wlan0-1'
option encryption 'psk2'
option key '----------'
option ssid 'GL-MT3000-46f-Guest'
option macaddr '----------'
option guest '1'
option disabled '1'
option wds '1'
option isolate '0'
config wifi-iface 'guest5g'
option device 'radio1'
option network 'guest'
option mode 'ap'
option ifname 'wlan1-1'
option encryption 'psk2'
option key '----------'
option ssid 'GL-MT3000-46f-5G-Guest'
option guest '1'
option disabled '1'
option wds '1'
option isolate '0'
config wifi-iface 'sta'
option mode 'sta'
option ifname 'sta0'
option device 'radio0'
option network 'wwan'
option ssid '----------'
option bssid '----------'
option macaddr '----------'
option encryption 'none'
For DHCP:
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '0'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
option filter_aaaa '0'
option filter_a '0'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
option ra_slaac '1'
option force '1'
option ra_management '1'
list ra_flags 'other-config'
list ra_flags 'managed-config'
option ra_default '1'
list dns '------0000:0000:0000:0000:0001'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config domain
option name 'console.gl-inet.com'
option ip '192.168.8.1'
config domain
option name 'console.gl-inet.com'
option ip '::ffff:192.168.8.1'
config dhcp 'guest'
option interface 'guest'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv6 'server'
option ra 'server'
option ignore '0'
list dns 'fd------0001:0000:0000:0000:0001'
option ra_management '1'
option ra_default '1'
list ra_flags 'other-config'
list ra_flags 'managed-config'
config host
option mac '------'
option ip '192.168.8.184'
config host
option mac '------'
config host
option mac '------'
option ip '192.168.8.182'
config host
option mac '------'
option ip '192.168.8.194'
These are probably causing the issue , you reserved these devices however the dhcp limit of lan is 50, and starts on 100, this means these reserved clients goes above the limit.
This is true
I tried this only this morning in order to try to correct the problem. But it didn't. And I forgot to remove the reservation back.
But the problem was even before that
I really thank you for your dedicated help.
You're very good to know that I reserved those. Wow
In your wireless configuration i also see these entries, ive seen them on other topics aswell by other posters, so i believe its default baked in configuration by the firmware, however with openwrt this setting is not enabled by default, you can set entries to 0.
Unless you really plan to use roaming , this might be also a issue indicator some wifi clients don't play well when they 'think' they should roam.
No it is not a default setting
But yes, it was suggested on a forum and I tried it and didn't work.
I just removed the reservation.
Should it be possible to assign them with a given IP address, on order to prevent them from disconnecting spontaneously? (No idea if this is even possible)
And is it usually better to turn on or off ivp6?
you can try giving them a reserved ip but the client still request a lease.
but i wonder if the device really disconnects or if it is the internet blocking it, what happens if you reserve it and then ping?
most of these iot devices tunnel through servers remotely and make it manageable from the phone app which basicly just loads up a external webpage with buttons, like @LupusE said it could be a issue with cgnat and they block it remotely.
In some cases it can help with firewall/nat issues but ipv6 also gives alot of complexity some features in gl-inet are still very experimental under ipv6 or features will not work, on the other hand if these iot are matter devices and the claims on reddit hold true that these must require ipv6 then you may want to look into that, as for now if it is not necessary don't use it
I really thank you so much for your prompt replies. Your were very helpful in many ways.
Hope I will get an answer in the future. It so, I will post it here.
Thanks again.
I finally probable got what is happening.
But sadly won't be able to get it to work
I just bought this new eufy x10 vacuum cleaner robot and couldn't connect it.
So more investigations were done.
The problem is not the router.
The problem is that the captive portal I am connected to is only 5Ghz.
So I think that despite using 2.4 on beryl, it won't be able to do this conversion. It is only labeled as 2.4.
Thanks for those who to tried to help.