Can't install TOR firmware on AR300M


I’m running V2.25 on the AR300M. I’m trying to flash openwrt-ar300m-ubi-tor-1.4.img (md5: 02195a8e0f9a5bacc666a76485a5a688) but I keep getting an error. The verification returns the same md5sum and gives an error “<span style=“color: red;”>Error: Firmware is not for this hardware.”</span> I’m pretty sure I’m using the right FW here. Can someone point me in the right direction? (I’ve also tried the .bin file just in case it was running from nor flash, but the same error).


Also, as a side question. I want to ensure that the nor has 2.25 on it in case anything goes wrong (I think the router cam with 2.20 on it). How can I flash that?




In case anyone else has the same problem, I found the answer at Overview - GL.iNet Docs. Basically I was using the .img file but to flash on a working system you need to use the .tar :).

  • openwrt-ar71xx-generic-gl-ar300m-squashfs-sysupgrade.bin, for nor flash
  • openwrt-ar71xx-nand-gl-ar300m-squashfs-sysupgrade.tar, for nand flash firmware upgrade inside of a working Openwrt firmware
  • openwrt-ar71xx-nand-gl-ar300m-ubi.img, for initial nand flash firmware build, this is used when upgrading using uboot.
I still have one issue though. I can't get the switch working to boot into the desired FW. It always boots into NAND. I can set the boot failure to 3 and get into the NOR flash but would like to use the switch. Help here is appreciated.

Hi @Simon81, to get the switch working, you need to upgrade the uboot. I don’t encourage you to do this.

In order always boot into nor firmware, you can set boot failure to 3 in both your firmware.

You can do this in /etc/rc.local

So everytime the root boot it will set bootcount to 3 so you will always boot into nor.