Can't install wpad-mesh-openssl on MT6000

can not install tmesh support wpad-mesh-openssl

The package wpad-mesh-openssl does not exist in the repo the MT6000 uses.
(At least not on my firmware 4.5.5)

So, how to setup openwrt mesh with the MT6000 and other openwrt router ?

You can’t.

At least not with the GL firmware. Maybe with plain OpenWrt.
I mean, ofc, you could grab some packages from the OpenWrt repo itself … but this is behind of scope here, I would say.

This what get when install the wpad-mesh-openssl …

Executing package manager

Installing wpad-mesh-openssl (2023-09-08-e5ccbfc6-3) to root…

Downloading https://fw.gl-inet.com/releases/v23.05.0/packages-4.5/aarch64_cortex-a53/packages/wpad-mesh-openssl_2023-09-08-e5ccbfc6-3_aarch64_cortex-a53.ipk

Not downgrading package hostapd-common on root from 2023-09-08-e5ccbfc6-4 to 2023-09-08-e5ccbfc6-3.

Errors

Collected errors:

  • opkg_install_cmd: Cannot install package wpad-mesh-openssl.

The opkg install command failed with code 255.

Flint 2 does not support mesh. You could use access point or WiFi extented.

It does support mesh, but you need to use a wired backhaul because the Flint 2 isn’t a tri-band router.

You can technically create a wireless mesh network, but you’d be sacrificing either your 2.4GHz band or your 5GHz band. And with the state of 2.4GHz on the Flint 2 it’d currently be a horrible idea.

Anyway, here’s two videos. One guides you through setting up a mesh network and the other shows you how to enable fast roaming.

You don’t sacrifice a band it just shares it along with backhaul. Clients can connect to the same band. If we’re talking about performance that’s another story ofcourse.

Those videos are really bad though. Try actually doing it and come back when after a couple hours the mesh nodes get lost since he didn’t at a minimum set up mesh11sd parameters.

Set up batman-adv.

When did you try using mesh on a dual band router without batman? I’m asking because I’ve tested this common mesh setup via a different router in the past and it refused to connect to the mesh network while also allowing clients to connect on the same band.

Admittedly, when I tested mesh in mid 2020 I was using an older version of OpenWrt and the identical routers were low end when compared to the Flint 2, so maybe something’s changed since then.

My setup was actually much like what’s shown in that first video and I don’t recall installing mesh11sd and setting any parameters? For me it all “just worked” and after looking at the OpenWrt forum it seems like it’s not essential unless you’re experiencing issues.

The second video seems perfectly fine to me, since it’s not even covering mesh. It’s showing you how to setup access points with fast roaming, which is going to perform far better than mesh on a dual band router anyway.

But then definitely don’t install mesh11sd.

https://forum.openwrt.org/t/80211s-batman-adv-and-or-mesh11sd/157233

Not sure what the actual problem is.
I’m running a mesh network from the MT6000 with 2 additional APs.
As a first step, I have installed the full wpad-openssl package (from the official GL.iNet repo) onto the Flint 2. Admittedly, the mesh11sd package is not available, though.
Anyway, my mesh seems to work like a charm. Maybe I should mention that the MT6000 is running on the 4.5.5 stable release (2024-01-05 10:09:25 (UTC+00:00))
For APs I’m using Z…l WSM20 routers running on OpenWrt and converted to “dumb access points”. On these two, I have installed the mesh11sd package. Can’t say, though, if this was strictly necessary.

What is the state of things with mesh in June '24?
I have Flint2 and firmware 4.5.8 release 4 based on kernel 5.4.238 and OpenWRT 21. Installed packages wpad-mesh-openssl and mesh11sd. When I go to Interfaces -> Wireless -> Edit interface, the only 2 options for Mode are "AP" and "Client". Even my old AR300M gives me a ton of options, including "802.11s". Is there a firmware I can upgrade/downgrade to to be able to use mesh? Currently reluctant to use clean OpenWRT firmware, but I will consider this option if necessary.

Flint 2 with Firmware 4.5.8 uses the MTK driver - no additional settings available.
Try the OpenWrt 24 open-source driver based firmware: GL.iNet download center

Yeah, thanks, that actually worked... as far as getting the options. What didn't work is connecting via mesh to my other router AR300M that I want to use as the dumb AP. I set the 2nd router to AP mode, disabled DHCP and firewall, set up wireless interface exactly how on Flint2 but they both refuse to connect to each other. I set up the same channel, frequency, security, key all of those settings are exact match.
The only thing I noticed that in the status of AR300M it displays Security "None", on Flint2 it shows CCMP WPA3 like it's supposed to. But even the author of the above video had the same bug in luci and mesh worked for him
EDIT: both are running the latest beta official firmware

What do you think will happen while enabling 'mesh'?
It's not like this kind of mesh other routers have.

I'd expect 2nd node to connect to the first. Honestly, never experienced mesh on any other routers, but expect some sort of acknowledgement that the two nodes communicate and a new AP should show up in the list of networks when I scan.
I'd much rather opt in fast roaming if I had proper hardware infrastructure but I don't

Did you read this wonderful article?

https://openwrt.org/docs/guide-user/network/wifi/mesh/80211s#warning_are_you_sure_you_want_a_mesh

Take a look into the WARNING Are you sure you want a mesh? paragraph :smile:

Of course, everyone points out to that article in mesh-related topics. But like I said above, if I had Ethernet laying around I would opt in 802.11r fast roaming, but I don't

Can't you just go with repeater then?

I tried that, my phone hangs on to the main router until it physically loses signal, then it may switch. It doesn't switch even when the repeater signal strength is 100% and the main router signal is 5%. There was nothing seamless about that setup