Can't log in (S/N?) and DNS fails if VPN is on

I have a GL-AR300M. I use it as a travel router for VPN to my home LAN, my office or to providers when I am in China. I love this little guy! However, its been a few months since I last had to hit the road but I’ve got another trip upcoming and I am making sure all my gear works.

There was an update to my AR300M and I installed it. At this point I can’t tell you what version it is because I can no longer log in to the web interface. So I have 2 problems:

  1. I cannot log in.

The login screen now has 2 fields that seem to both be mandatory. One is the normal “Password” field and the other says “S/N (What is this?)”. I did click the “What is this” link and I cannot find reference to the S/N in the online docs using both its own and a startpage (google) site search though I am sure it is there somewhere?

I assumed it referred to the serial number of my unit (printed on a sticker on the bottom ) but that is not working. I am sure the password is correct as I used it minutes prior to updating. Before I factory reset this device, to save some time I thought I’d create an account here and ask for help.

  1. DNS fails when VPN is on

I setup the switch to turn VPN on and off. At first I couldn’t load the the “What is this?” link and i couldn’t figure out why, then I flipped the switch (turning off VPN) and it loaded. After some playing with it I have determined that DNS does not resolve if VPN is on. I can ping IP address no problem but domain names all fail to resolve.

I saw this AR750 as OpenVPN client, no DNS for far network. Can anyone tell me if the solution in that thread (for a AR750) also applies to my AR300M and is it actually the solution to my no DNS when VPN is on problem?


Seems like the update went wrong. Please go here and follow the debricking instructions:

Since you will need to configure all from scratch, download the new V3 testing firmware here too:

Let me know how it goes. The DNS is also fixed in the V3 firmware.

1 Like

Thank you! I will follow those instructions.

I am back up! Just a quick follow up/report.

The firmware 3.005 did not seem to take. In the unbrick mode, it would upload and begin the flash but it never seemed to complete. I did redownload it a couple times, and I also tried getting it from here: and verified the signature.

I left it for 30 minutes each time I attempted to flash it via unbrick mode. My AR300M would only light the left LED (looking at it from the front) and never seemed to restart itself. I could not reach it on any IP address nor detect its IP on scans of my LAN.

I finally gave up and did a normal reboot and 2.20 came up for some reason. I then tried to upload the 3.005 firmware again using the 2.20 firmware update page (html/index?index&firmware_status). It gave me an error that it was not the right firmware for my device. I tried redownloading 3.005 a couple times but kept getting the same error.

After one reboot, I was surprised to see that my AR300M seemingly updated itself to 2.27. I then factory reset it in the settings but it stayed at 2.27. So I set it back up again and now I am no longer having DNS issues when VPN is on.

I have no idea how this happened but I am good to go! As an aside, if you have any influence, I’d be in for an AR750 from Amazon if it goes on any kind of sale on Black Friday :wink:

Thanks again!

shouldn’t you use
.tar is used for upgrade in current openwrt
.img is used for upgrade in uboot.

1 Like

OOps, then that explains the “wrong device” error message! Thanks, I’ll try it again with the .tar later tonight.