Can't login to gl GUI page anymore. Error 500! ( Flint 2)

Hello
I rebooted the device and after reboot i tried to log into the deivce firmware GUI and it does not go in and returns with an error saying i need to reboot the device. i did reboot with no luck.
I can log into Luci BTW

This sometimes happens when the filesystem is mounted as read only. Ssh into the box and check the permissions of the mounted partitions.

You can also check the logs for abnormal activities by running logread.

1 Like

Sorry ive forgotten how to do that with mounted filesystem.
However i reset the device and restored it back via luci ( i had a restore file )
im back in.
An issue thou…
When trying to log in through Https. i get security warnings. I didnt get any warning in https on mac.
Am i doing somethign wroong?
Thx

I had the same problem, solved by loading/updating the same firmware via LUCI while keeping the settings

Hello. elaborate please. also do you have the same issue with HTTPS?

As you are using https, it is supposed to have warining.

But some antivirus or firewall software may also prevent you to input any password in non-secure website, causing such errors. If this is the case, you may need to add exceptions in your firewall settings.

1 Like

No antivirus on mac. BTW i didnt have this issue before i reset the device. the device itself when i put 192.168.8.1 always brought up https version itself.
Im more keen to use https so therefor in case someone is in my nat, they wont be avble to sniff for device’s password when i login through HTTP
Do you know what i mean alzhao?

Yes I know what you mean. But still not sure about the reason of cannot login.

I can login. thing is i dont want to add that exception. because that exception will make it non safe. same as http. i was saying i did not get that https warning before. makes me wonder what has triggered it. considering i has issue login in to the router as well. ( er 500) which they said its due to read only file. but no way to confirm it. i think it needs to be addressed further and see what really causes this if “this happens sometimes”

Anyway… Still no solid reply to put it as “solution” here

Could you have a look into the nginx log files via SSH?

1 Like

Its sorted now after reset and restore.
But if it helps now, sure i can

It uses self-signed cert. You must have clicked on enable https. It will NOT make you insecure if you will add this cert as “trusted”. This will ensure that traffic between you and router will be encrypted

1 Like