Can't mount USB drive

Hi folks,

I have a new GL-SFT1200, which I bought mainly to serve media off a large SSD to my family while traveling in the car, etc. The first time I tried it, it seemed to work fine - but now it either won’t acknowledge the drive at all (even after reboots etc), or else it mounts just a “GL-Samba” directory that it insists is empty.

I tried resetting and starting over (re-installing file sharing etc) but that didn’t seem to help either.

I can shell into the router, but I’m not sure how to see logs or debug. I’d appreciate help - thanks in advance!

the command will print logs.


Thank you! Poking around the shell a bit, I can now see that the SSD mounted fine, and I can see all the files there. But it wasn’t sharing over samba.

Eventually I noticed in the “File sharing” tab of the admin page that it was using an old mount point as the “current directory” for file sharing. Once I changed the “current directory” to the mounted drive, everything seemed to work fine. Is there a way for the current smb directory to automatically reflect the drive that is now mounted? Thanks again …

It does not support auto-recognition.
An alternative is to mount the /mnt directory directly. because it may be mounted to the /mnt/sda1 or /mnt/sdb1 path.

I see ok, thank you.

Just tried again from reboot to confirm this is the issue, and now again it won’t mount at all; when I try to mount manually (with eg mount -t exfat /dev/sda1 /mnt/[dir]) it doesn’t recognize /dev/sda1 or /dev/sdb1. How can I use logread to see the problem?

Use the following command to check whether the driver recognizes the SSD

find /sys/devices/platform/17000000.usb/usb1/1-1/ -name sd*

I believe quotes (") are necessary:

find /sys/devices/platform/17000000.usb/usb1/1-1/ -name “sd*”

I do not work for and I do not have formal association with GL.iNet