Can't ping the stations from the router (GL-AR300M)

I have a problem with the ping function on AR300M.
After I set up the wireless network, the router can ping the stations in the WLAN, just like:

root@OpenWrt:~# arp
IP address       HW type     Flags       HW address            Mask     Device
192.168.2.1      0x1         0x2         00:22:2d:80:1f:30     *        eth0
192.168.8.190    0x1         0x2         82:92:8e:c5:dc:ef     *        br-lan
192.168.8.140    0x1         0x2         ec:22:80:0e:c5:91     *        br-lan
192.168.8.156    0x1         0x0         84:10:0d:1d:3a:5e     *        br-lan
192.168.8.135    0x1         0x0         80:01:84:16:fd:a3     *        br-lan
192.168.8.137    0x1         0x2         80:7a:bf:6d:a0:37     *        br-lan
192.168.8.141    0x1         0x2         c8:3c:85:61:03:ad     *        br-lan
192.168.8.149    0x1         0x2         30:5a:3a:f0:7f:1e     *        br-lan
root@OpenWrt:~# ping 192.168.8.190
PING 192.168.8.190 (192.168.8.190): 56 data bytes
^C
--- 192.168.8.190 ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss
root@OpenWrt:~# ping 192.168.8.140
PING 192.168.8.140 (192.168.8.140): 56 data bytes
^C
--- 192.168.8.140 ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss
root@OpenWrt:~#

However, the router can ping the device out of WLAN, like:

root@OpenWrt:~# ping 140.113.1.1
PING 140.113.1.1 (140.113.1.1): 56 data bytes
64 bytes from 140.113.1.1: seq=0 ttl=58 time=3.218 ms
64 bytes from 140.113.1.1: seq=1 ttl=58 time=2.648 ms
64 bytes from 140.113.1.1: seq=2 ttl=58 time=2.300 ms
^C
--- 140.113.1.1 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 2.300/2.722/3.218 ms
root@OpenWrt:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=120 time=4.496 ms
64 bytes from 8.8.8.8: seq=1 ttl=120 time=4.497 ms
64 bytes from 8.8.8.8: seq=2 ttl=120 time=4.415 ms
^C
--- 8.8.8.8 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 4.415/4.469/4.497 ms

The station in WLAN can ping the router, but cannot ping other devices in WLAN.
I had tried to disable the firewall, but the results are similar.
I had also found some discussions on the web, and some point out the issue of “AP isolate mode”.

root@OpenWrt:~# cat /var/run/hostapd-phy0.conf
driver=nl80211
logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
country_code=US
ieee80211d=1
hw_mode=g
channel=11

ieee80211n=1
ht_coex=0
ht_capab=[LDPC][SHORT-GI-20][SHORT-GI-40][TX-STBC][RX-STBC1][DSSS_CCK-40]

interface=wlan0-1
ctrl_interface=/var/run/hostapd
ap_isolate=1
disassoc_low_ack=1
preamble=1
wmm_enabled=1
ignore_broadcast_ssid=0
uapsd_advertisement_enabled=1
wpa_passphrase=mbwcl711
auth_algs=1
wpa=3
wpa_pairwise=CCMP
ssid=openwrt
bridge=br-lan
wpa_key_mgmt=WPA-PSK
okc=0
disable_pmksa_caching=1
bssid=e6:95:6e:44:82:6b

Unfortunately, I cannot just set "option isolate ‘0’ " in /etc/config/ wireless to change the policy.
The following is my configuration.

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/qca953x_wmac'
        option htmode 'HT20'
        option txpower '23'
        option country 'US'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option encryption 'psk-mixed'
        option ssid 'openwrt'
        option key 'mbwcl711'
        option isolate '0'
        option network 'lan'

config wifi-iface 'monitor'
        option device 'radio0'
        option mode 'monitor'
        option isolate '0'

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd62:90a5:7188::/48'

config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.8.1'
        option _orig_ifname 'eth1 wlan0-1'
        option _orig_bridge 'true'
        option ifname 'eth1'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

The firmware version is OpenWrt Chaos Calmer 15.05 r47065 / LuCI for-15.05 branch (git-17.136.58961-13aa5ff).
Does anyone have the idea about how to fix this bug?
Or any further information I need to provide for tracing this issue?
Thank you.

should this be a problem of your station?

If 192.168.8.190 reject your pings then you have no reply.

Can you check the firewall in the stations?

Hello alzhao,

Thanks for your prompt reply. I will try to verify the setting.
By the way, the purpose of the experiment is to monitor the QoS on routers.
I want to write a program, change the MCS mode, and record the PER without any program on station.
I only think about the PING function can complete the tasks.
Maybe you can give me some hints to do it.
Thank you.

The problem is caused by the Windows Firewall.
After disable the firewall, the ping function is correct now.

root@OpenWrt:~# arp
IP address       HW type     Flags       HW address            Mask     Device
192.168.8.209    0x1         0x2         0c:51:01:ba:39:72     *        br-lan
192.168.2.1      0x1         0x2         00:22:2d:80:1f:30     *        eth0
192.168.8.190    0x1         0x2         82:92:8e:c5:dc:ef     *        br-lan
192.168.8.140    0x1         0x2         ec:22:80:0e:c5:91     *        br-lan
192.168.8.156    0x1         0x0         84:10:0d:1d:3a:5e     *        br-lan
192.168.8.106    0x1         0x0         00:21:6b:f7:e3:ce     *        br-lan
169.254.35.201   0x1         0x2         e0:4f:43:70:dc:66     *        br-lan
192.168.8.108    0x1         0x2         e0:4f:43:70:dc:66     *        br-lan
192.168.8.135    0x1         0x0         80:01:84:16:fd:a3     *        br-lan
192.168.8.137    0x1         0x2         80:7a:bf:6d:a0:37     *        br-lan
192.168.8.141    0x1         0x0         c8:3c:85:61:03:ad     *        br-lan
192.168.0.163    0x1         0x2         00:21:6b:f7:e3:ce     *        br-lan
192.168.8.149    0x1         0x2         30:5a:3a:f0:7f:1e     *        br-lan
root@OpenWrt:~# ping 192.168.8.140
PING 192.168.8.140 (192.168.8.140): 56 data bytes
64 bytes from 192.168.8.140: seq=0 ttl=128 time=2.204 ms
64 bytes from 192.168.8.140: seq=1 ttl=128 time=2.807 ms
64 bytes from 192.168.8.140: seq=2 ttl=128 time=2.268 ms
64 bytes from 192.168.8.140: seq=3 ttl=128 time=3.519 ms
64 bytes from 192.168.8.140: seq=4 ttl=128 time=5.341 ms
64 bytes from 192.168.8.140: seq=5 ttl=128 time=1.847 ms
^C
--- 192.168.8.140 ping statistics ---
6 packets transmitted, 6 packets received, 0% packet loss
round-trip min/avg/max = 1.847/2.997/5.341 ms

Many thanks for alzhao’s help!

You are welcome!
Thanks for reporting back.