Can't set up GL-AR75OS = URGENT HELP NEEDED!

I am using a MacBook Air. I powered on by connecting to the computer’s USB port, plugged the ethernet into my wifi device and into the router as asked to do and followed instructions. But when I type in http//192.168.8.1 using Google Chrome as my browser, a message flashes up saying that I cannot be connected to this server.
I have tried going to docs.gl-inet.com for more detailed instructions, but don’t know if I’m supposed to be admin or what?
Eventually, the system asks me to type in the http//192.168.1 address into the Google browser and guess what - I have the same problem and I cannot connect to this server!!
I’ve tried pressing and holding the reset button and starting again, and am now going down the bottom of the garden to scream!!! Someone please rescue me!!!

Not enough “juice” - you need at least 1A to power the AR750S which is by using a 2xUSB -> 1xUSB
You are only providing 500mA with 1 USB port. I have used the above cable and the AR750S works.

(https://www.ebay.com.au/itm/USB-2-0-Female-A-to-Dual-A-Male-Extra-Power-Data-Y-Extension-Cable/173655597776?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649)

1 Like

Now sure if it is power problem.

But I cannot understand how you connect.

Here is a video about how to connect to the web panel. https://www.youtube.com/watch?v=4Xy1l2ImJro
It is for windows, but it contains a very important step: check the IP address your computer got from the router. It should be 192.168.8.x