Can't upgrade MT3000 to version 4.2.3 - "The uploaded file is too big"

Any thoughts?

What is the size of the firmware file you uploaded? It should be 58.07 MB.

I do not work for and I do not have formal association with GL.iNet

Can you check the available memory of the router?
Or you can try to upgrade via Uboot.

Yes, the firmware is about 58MB. If that’s the right size, why would the router complain?

If I try with Uboot, would that update the device exactly as with the other method? (or this Uboot Firmware is less featured?)

Firmware installed using Uboot is no different than firmware installed on Admin Panel. It just doesn’t save the settings when upgrading.
Note that you need to download another .img format firmware installation file for Uboot.

Before trying Uboot, maybe you can reset the router to factory settings and retry the same upgrade again. I always back up the existing settings before any upgrade just in case.

I tried both ways, still didn’t work.

Any other ideas?

Ok, sorry about the confusion. I just realized my unit is the GT-MT1300 (Beryl) and not the GT-MT3000 (Beryl AX). I was trying to install the MT3000 firmware on the MT1300 device. Once I chose the right one, it worked. I am glad I could restore my settings before doing this.