Can't use VPN nor use 2nd router as server to get home IP

1. I just bought 2 Opal routers to use one as a server and connect the other to it in order to use my home IP address even if not at home. It’s not working and I don’t know why. DNS is configured properly and the port forwarding in my home’s router is already up. The DDNS code (something like this [xxxxxxx . glddns . com]) was properly added while configuring the WireGuard Client with the respective [Interface] & [Peer] text. Not working at all.

  1. I thought the problem was how I configured my home router or something related to the steps previously explained, so I decided to try with ExpressVPN and it is still not working. I restored the router, updated it, and did everything mentioned in your videos, even reviewed the vid “the 4 common mistakes” from GL inet (the problem wasn’t related to that), nothing works. The text after trying to use ExpressVPN (some numbers substituted with X’s:

Incoming Control Channel Authentication: Using 512 bit message hash ‘SHA512’ for HMAC authentication
TCP/UDP: Preserving recently used remote address: [AF_INET]XXX.61.XXX.10:11XX
Socket Buffers: R=[172032->3440XX] S=[172032->3440XX]
UDP link local: (not bound)
UDP link remote: [AF_INET]XXX.61.XXX.10:11XX/

What can I do? It’s somehow urgent and have spent most of the day trying without any success. Help!

It seems that the router and the server cannot establish an UPD connection. Can you ping the server address?

For the 1st part of my request
I don’t know if this is the right information:
VPN > WireGuard Server > Status
IP Address:1
VPN > WireGuard Server > Management
Client IP:

For the 2nd request, now the VPN is working on one of them, did the same thing as yesterday and today it worked, is it usually that unstable? The one that’s not working says this:

Control Channel: TLSv1.3, cipher TLSv1.3 TLS_AES_256_GCM_SHA384, 2048 bit RSA
[Server-9483-0a] Peer Connection Initiated with [AF_INET]
SENT CONTROL [Server-9483-0a
AUTH: Received control message: AUTH_FAILED
SIGTERM[soft,auth-failure] received, process exiting
VPN client failed to connect. This may be because of wrong configuration, unsupported parameters or terminated by the server. Please choose another VPN profile or abort the connection.

I tried ExpressVPN and did not reappear your question. What is your firmware version?