Captive portal - fails to login to WiFi in hotel (gl-mt1300)

It usually works, but this time it did not. This hotel I am in right here and now (and for another 2 nights) has a weird redirect once you go to the browser, which apparently does not get triggered if logging in via the modem.

Any suggestions to what I can do to use my Beryl modem to login? Usually it just goes to the connection page and forwards everything to my browser on laptop. This time it did not.

It worked, and the issue was that there is probably something wrong with their TSL. The error message by Firefox was the following: SSL_ERROR_DOWNGRADE_WITH_EARLY_DATA

This in turn, if clicking “read more” prompted my Ubuntu to open GNOME and some session was established that pushed through the connection and made it work.

I still dont know why it did not work, and why it worked after. One of the most confusing aspects about being in hotels is the captive portals and their incredibly bad ways of authenticating clients.

I just google and find some links. Does this one help?

May also try other browsers