Captive Portal problem

Hi, I’m fairly new to this (both the site and travel routers). I know many people have experienced issues with captive portals, and the goto answer appears to be

config rebind_protection ‘0’

But, I can’t get this to work. The captive portal attempts to open, but nothing loads. I’ve even tried logging in on a device, then cloning my MAC address to no avail. I’m at a loss.


Edit: I apparently didn’t finish my post

Can you try the latest firmware? You can disable rebind_protection in the UI->Internet->Custom DNS page.

You may need to reconnect your wifi.

alzhao, I should have mentioned that I have tried both v2.263 and v2. 27 using the GUI as well as manually editing /etc/config/dhcp. Neither has worked.

You may attach your browser screen shot so that we can check the url. It is also good to know where is the capital portal e.g. which hotel.

The captive portal is in a dorm room, not a hotel, and it requires username and password to enable internet access, but is restricted to one device per account. I’m not there at the moment, but I’ll try to get a screen shot later.

I’ve solved the problem with the captive portal (somehow, I’m still not sure exactly how). If I ssh into the router, it’s definitely connected to the internet. Now the problem is that I cannot access the internet from my private wifi network.

generally the portal will block http and https pages. If you use other protocol you may have Internet.

I’ve managed to get a VPN up and running, which provides full access. Thanks for the help!