Carelessly changed MTU setting in LUCI

Hi all,

I am testing MTU here. My setting is clients are connect to the internet via 3 ways: GLInet with VPN, GLInet without VPN, straight to ISP Router.

I tested the ping -f -l xxxx via windows command line and the lowest result without packet loss are:

  1. Via GLInet with VPN, the xxxx = 1392
  2. Via GLInet without VPN, the xxxx = 1462
  3. Straight to ISP Router, the xxxx = 1464

In the ISP Router, WAN Configuration: MRU = 1492

FYI. I changed the MTU Override number in the LAN setting in AR150 LUCI to some number. to 1392. Is it advisable to change default LUCI setting? Did I just messed up with LUCI?

I don’t see a reason why you changed the MTU.

The VPN MTU is different from the normal one. Just change it within the VPN client settings?

1 Like

I thought by lowering the number, the connection will be better for other devices too when NOT using the VPN via the GLInet router.

Okay, I will only change the VPN client setting. I already carelessly changed the LAN MTU in LUCI to that lower number 1392 and then changed it back to 1500.

Hope there is not something fundamental I changed there… I only changed the override MTU number. :slightly_frowning_face:

I think the speed via VPN is slower now, compared before I changed the MTU setting.

So, anybody is NOT advised to change MTU setting anywhere except on the client devices themselves.

Is that true?

I would not label it as “not advised” but more like “it’s not necessary mostly”

1 Like

If I alternatingly using/not using VPN in the router, setting the lowest MTU in the router client can still be compatible with MTU without VPN right?

Because MTU with VPN is lower but safer since no packet will be lost.

Reducing MTU is only recommend if it’s necessary. Much testing needed.