Client-Server with Two Slates

Hi,

I’m having problems connecting my slates. I have them connected like this: personal modem → Slate (ethernet) as server → Slate as client.

This all worked when I was in the USA. I left the USA and now the two won’t connect. The server is online but the client is saying it is connecting. This is the log on the client:

Thu Nov 24 21:21:31 2022 user.notice wireguard-debug: USER=root ifname=wgclient ACTION=REKEY-TIMEOUT SHLVL=2 HOME=/ HOTPLUG_TYPE=wireguard LOGNAME=root DEVICENAME= TERM=linux SUBSYSTEM=wireguard PATH=/usr/sbin:/usr/bin:/sbin:/bin PWD=/

Does anyone have any advice? I don’t see why this is happening. I’ve tried doing a hard reset on both devices and nothing has helped.

When you did your testing in the USA, did you try where your client was using a different network (i.e. not behind your modem)? In other words, are you confident that your personal modem is properly forwarding Wireguard traffic to your slate-as-server?

(also, I assume you intend the “slate as client” arrow to be pointing the other way - that is to say, you’ve now got the slate-as-client in Djibouti (or some other country) and you’re trying to connect back home, rather than still having the second slate-as-client connected to the slate-as-server, right?)

When I did my testing, I was in a different location than the server so I was on a different network and everything worked for a week.

Yes, my arrow is pointed in the wrong direction.

You mentioned doing a hard reset on both devices which implies you still have access to the server (via OpenVPN, perhaps?) Are there any logs on that side?

I have access to it though a family member who is helping me. Here’s the log I’m getting from the server:

“Thu Nov 24 22:38:55 2022 daemon.notice netifd: Interface ‘wgserver’ is setting up now\nThu Nov 24 22:38:56 2022 daemon.notice netifd: Interface ‘wgserver’ is now up\nThu Nov 24 22:38:56 2022 daemon.notice netifd: Network device ‘wgserver’ link is up\nThu Nov 24 22:38:56 2022 kern.info kernel: [ 25.840938] IPv6: ADDRCONF(NETDEV_UP): wgserver: link is not ready\nThu Nov 24 22:39:01 2022 user.notice firewall: Reloading firewall due to ifup of wgserver (wgserver)\n”

At your remote location have you tried other access points? Where I’m at now, the city has free access points all over town, but they all block my Wireguard access. Using OpenVPN over TCP on port 443 works for me at these locations.

I have no problems using Wireguard at my Airbnb or using Wireguard on the free WIFI at McDonald’s. Some places just block Wireguard, so that is why I make sure my VPN server supports multiple protocols and ports.

1 Like

I have tried the Wi-Fi at the home I’m in, and also my phone’s hotspot. Nothing changed on either one. But will try setting up an OpenVPN port to try that.

I will second that I’ve been in situations where OpenVPN didn’t work but Wireguard did, and vice versa. It’s not common but I’ve had it happen probably 3-4 times in the last couple of years.

Where are you now? Are you in an Internet sensored region?