"Clients" screen incorrect if one device connected more than once

RN my laptop is connected via WiFi and Ethernet, and I see two “Self” entries. I’m used to not seeing the “Name” field entry being filled in for the 2nd instance of a device (on previous SW versions it used to hae a “*” there but now it says “Unknown”) but the “IP+MAC” field has the same IP address for both entries (the WiFi, which correctly identifies my laptop in the “Name” field is showing “.8.103”, but that’s actually the IP of my Ethernet connection (and the “Name” field for the Ethernet one is “Unknown”).

Does this make sense? Ah, let me just grab a screenshot:


When the router can’t get the device name, it will display “Unknown”. This is different from the old version.

it might be a bug, Did you manually set the IP address on your laptop?

Does the wifi connect as well? What is the real IP on wifi?

This also happened to me, and it happened A LOT of times even on old UI using Mango, Creta and Beryl.
When assigning static IP and Hostnames, at some points the system showed the same IP for 2 particular devices.
On old UI, I fixed it deleting tertinfo from vart/tertf/tertfinfo, deleting static IP from GLUI, assigning IP and hostnames manually in etc/config/dhcp and rebooting both router AND the devices affected.

No, assigned via DHCP.

Any chance y’all can fix the “Unknown”/“*” name issue on the 2nd instance of a connected device?

Yeah, both have a working address assigned from DHCP:

$ ip addr show eth0
60: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:e0:4c:68:00:b5 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute eth0
       valid_lft 34491sec preferred_lft 34491sec
    inet6 fe80::62fc:ad27:b318:eec2/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
$ ip addr show wlan0
59: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether c0:b8:83:1f:f4:41 brd ff:ff:ff:ff:ff:ff
    altname wlp0s20f3
    inet brd scope global dynamic noprefixroute wlan0
       valid_lft 23316sec preferred_lft 23316sec
    inet6 fe80::3067:80a0:b809:b043/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         UG    100    0        0 eth0
default         UG    600    0        0 wlan0

We have tried, but in many cases, the device itself does not provide the name.
So our next version will allow users to set the device name manually on the router.

1 Like

In case it helps, iOS 15.X devices appear as “Unknown”, but older iOS devices (iOS 12.X) seem to be properly recognised.

Which method are you using to detect names? I can try to debug here as it seems to reproduce always.

iOS 15 will not give the device name if you use private WLAN address. You can turn it off on your phone, the steps are: “Settings” → “WLAN” → “i Icon” behind SSID → Private WLAN Address.

Private WLAN Addresses Feature will be enabled by default on iOS 14 and later.
Similar Features also exists on Android 10 or Windows 10(or versions above that).

1 Like

Why is that? If I connect via WiFi only, it reports the right name. If I connect via Ethernet only, it reports the right name. If I connect with both, whichever one connects last gets “Unknown”.

Perhaps this is tied to the actual bug reported here, where the IP address of the 2nd-assigned device shows in the UI of the 1st-assigned device as well? I don’t have any static IP entries.

We will try to analyze this bug. Is your device a Dell XPS 13 (7390)?

This particular device is, yes. But it also happens with my Raspberry Pis, my Amazon Fire Sticks, and my Chromebooks- anything that has the ability to connect via two interfaces; the first interface given a lease is named, the 2nd one comes up as “*” or “Unknown” (depending on UI version).

Just a guess, but maybe we’re inadvertently discarding the 2nd instance of a name (i.e., we’re using the name internally as a key and discarding it if it’s not the only instance)?

Oh, and while the “Name” issue persists, I’d loaded last night’s Beta and it appears the IP address duplication bug is fixed, so thanks for that!