Cnnecting to GL-MT300N-V2 oon ethernet while on wi-fi

I have a problem with Torguard on my GL. When it fails to authenticate, it kills my connection to the GL via wi-fi and I have to connect to another network then reconnect to the GL to recover (on Ubuntu 16). So I decided to connect to the GL via ethernet while simultaneously connected to the internet via wi-fi. This way I can research problems even when the GL loses its internet connection. However, my browser won’t connect to GL while still active on the internet (on a wi-fi using 192.168.1.X). It’s either fi-fi active or ethernet active. Anyone able to do this?

Seems the router’s Ethernet ports are bridged. What is your firmware version? I think this problem has been fixed.

Latest firmware. 2.271. I installed it 7-13-18.

The firmware itself should have fixed bridge problem during boot. I am not sure if this problem is from old settings when you upgrade.

Can you please try two things:

First is the remove cables then plug them again. This will refresh the network settings. The IP address should be fixed. If not, then there should be a problem in the firmware settings.

Second is reset the firmware by holding the reset button for 10 seconds, until the LED flashes very quickly. This will clean everything and start over.

If not I need to check your network configurations if you can still login or ssh to the router.