Collection of spitz questions

The EP06 auto connect did not work for me, so I had to do a lot of research but I finally got things to a somewhat improved state using manual AT commands.

I set ttl to 65 using sysctl at the end of the system config file. Good idea? Yes or no?
Using AT I am able to get to the point where the MVNO gives me an IP, which I find by
using the AT status command …PADDR=1

But I am still able to issue AT commands so that makes me think that I am not actually connected.
My impression is that USB2 is used to command the modem but eth0 is connected to the PPP port.
How do I convey this IP into the system since auto configure just goes to ABORT?

If I issue a command that results in CONNECT 15000000 I am no longer able to issue AT commands.
That seems good, but the sequence of ++++ does not undo that and get me back to AT mode.???

Now also I have 5 active CID in EP06 NVRAM. I took over the first two with my own MVNO and modes
and the last 3 were already set up for verizon and I left them alone. All of this fooling around left me
in a condition where powerup results in bars but the banner in the GUI still says Verizon not the
carrier I am actually using (a Verizon MVNO).

LUCI is incredibly slow and I cannot figure out which interface I should be trying to configure: WAN, WAN6,
MODEM_1_1_2? If you don’t already understand the namespace of devices it is very hard to keep it
straight about which one you should be messing with and the docs on glinet are quite superficial.

Almost forgot, on powerup the gui for tethering comes and goes a few times. What is going on there?

Ideally I would like to set the top level data structures so that it configures correctly automatically but
there is really not enough guidance to do that. Advice, please?

I did set disabled to 0 in /etc/config/network

config interface ‘modem_1_1_2’
option ifname ‘wwan0’
option service ‘fdd_lte’
option apn ‘mymnvo’
option proto ‘qmi’
option device ‘/dev/cdc-wdm0’
option metric ‘40’
option disabled ‘0’

What model of router are you using?
Try the following configuration

You can abort the auto connection and use manual connection. Choose ttyUSB3 as data connection. It is more compatible than QMI mode.

About AT command, pls note there are ttyUSB2 and ttyUSB3.

You need to use ttyUSB2 as AT command and ttyUSB3 as data connection. You can also use ttyUSB3 as AT command and ttyUSB2 data. But once you use one port as data, you cannot use it as AT command at the same time.

1 Like

Thanks. How do I execute other AT commands automatically on boot in order to add band 66 and do carrier aggregation?

Once you lock band using AT command, it will keep this setting even after you reboot.