Config logread with rsyslog

i have a rsyslog server. but i cant send log from glinet to rsyslog server. pls help me to configure that.
already tried “logread -r ” but fail. idont get the logic. pls help ^^

output :
Fri May 21 09:16:53 2021 logread[14864]: failed to send log data to server:customport via tcp

Have you install rsyslog?

my device is GLinet B1300. there is no package rsyslog.
so i need another optional. like logread stream to my server rsyslog.
router send log to server. not server collect log from router.

Maybe you can add -u to use udp.


I’ve been trying like that. but still fail. I need steps for setting up glinet so I can send logs to the rsyslog server (ubuntu).

This can be configured in luci.

Pls check.