Configuring GL-AR150 as Access Point when WAN comes from USB tether

I have a new GL-AR150-Ext-2 that is getting it’s internet access via USB tether to a hotspot (Alcatel Linkzone 2). That part is working fine. The default GL-INET150 mode is Router. I want the GL-INET150 to act as an Access Point only, where it broadcasts a SSID, but other devices connected via its WIFI and LAN port get their IP address via DHCP from the hotspot, not the GL-INET150. I tried using the interface at More Settings / Network Mode to Access Point, but I get an error message that says, “To setup Access Point mode, you need to connect an Ethernet cable to the WAN port first.” I don’t have that option as the hotspot has a USB port but no Ethernet port. The reason I got the GL-INET150 was for its USB tethering capability. How do a setup the GL-INET150 as a true Access Point where connected devices get their router/gateway/DHCP info from the hotspot, not the GL-INET150? I upgraded to the latest firmware. Thank you.

Can you try to set up in Luci (advanced settings)?

This may be complicated.

First, you need to bridge the tethering interface (usb0 or eth2?) with lan (eth1)
Second, you need to configure dhcp to not broadcasting on lan interface.

Thanks for your reply alzhao. I have tried configuring it in Luci but it didn’t work for me. I tried bridging usb0/tether with lan/eth0 as well as br-lan. I also turned off firewall, dnsmasq, and odhcpd as per the Dumb AP instructions: [OpenWrt Wiki] Wireless Access Point / Dumb Access Point / Dumb AP. I usually just lose connection, but never get DHCP from the router/hotspot. I’m probably doing something wrong, but don’t understand well enough to know what it is.

I tried Bridged AP mode, [OpenWrt Wiki] Bridged AP, but probably didn’t get the settings right as the example wasn’t for a tethered USB connection. Even though I disabled and stopped firewall, dnsmasq, and odchpd in Network>Startup, it continues to serve up DHCP addresses to clients. I don’t seem to be able to pass DHCP from the hotspot/router through the GL-AR150.

Not sure if all settings are correct. But you can post screenshot to check?

Pls note the tethering interface has to enable bridge in the driver. Otherwise you cannot really bridge.

“Pls note the tethering interface has to enable bridge in the driver. Otherwise you cannot really bridge.” Wow. That’s pretty critical information. Isn’t the GL-AR150 the tethering interface? I’ve wasted enough time on this already, especially if it might never work. I think I’ll hold off until/unless GL.iNet comes up with a supported solution. For right now, I’m putting the GL-AR150 in the DMZ of the hotspot. It’s not ideal but it’s working.

Each connection, in Linux, is one network interface. Some interface support bridging some do not.

The easytether driver is not opensource so no idea how it works. I hope it support bridge by default.

As this is unknown, we should focus on what we can do: just give the detailed settings and hopefully someone with easytether experience can help.