Configuring Router as Wireless Repeater/Bridge Help! (GL-B2200)

I’m a novice at best so please bear with me.

I’ve been trying to configure my GL-B2200 routers as wireless repeaters, as it was purchased by someone who did not understand that it was an unsupported mesh network for the router setup being used.

While I’m able to set up a travel router from the same producer as this forum as a repeater, I’m having specific issues I’ll list with the GL-B2200 mesh routers while navigating the LuCI UI, in addition to listing basic information:

  • Main Router: ASUS RT-AX86U

  • Goal: Sending packets to the main router so that the DHCP can assign IP addresses, and not the secondary routers

  • Documentation I’ve looked at:
    a) [OpenWrt Wiki] Wi-Fi extender / repeater / bridge configuration
    b) More Settings - GL.iNet Docs
    (I might be misreading these or something, but I’ve hit a wall)

  • Setting up the mesh router as a repeater activates the DHCP server in them. Upon disabling it under ‘LAN’ under Network >> Interface >> LAN (Edit), it seems to still assign my test device under the IP 192.168.8.*** when I want the DHCP on the main router to assign 192.168.50.***, despite the IPv4 gateway (LAN) being entered as

If this forum allows post editing, I’ll update as time goes on. Thanks

Cannot fully understand what said.

But setting up repeater, you should just:

  1. reset B2200 if you messed up the settings etc.
  2. Go to more settings->network mode and choose extender

Both extender/repeater options assign IPs under a DHCP being run by the second router as 192.168.8.*** . I want the main router to assign the IPs under 192.168.50.***

When you use extender, it will assign IP of the main router, e.g. 192.168.50.x, not 8.x

Pls note: repeater is router mode.

that’s just not the case.

Looking at the network map on the main router, and running ‘arp -a’ in the terminal only shows the local network under 192.168.8.*** . It also shows up as 192.168.8.*** under the GL-net UI client list.

UPDATE: I was able to get the main router DHCP to assign IPs 192.168.50.*** and have devices connected to the mesh network routers to show up on the network map, but printing software doesn’t seem to recognize the IPs of the devices connected to the mesh routers. Tested with a device running DD-WRT and was able to get the printing software to work. Will update if I’m able to fix why.

UPDATE2: Decided to Hail Mary and restart the main router and then every router after and it worked

1 Like