Connecting OpenVPN to an Untangle OpenVPN Firewall


#1

I have downloaded the correct zip file which contains the needed ovpn, key, and cert, but when trying to apply I continually get an error message stating "You need to put your ca, key, crl, and cert in teh same zip file and upload. I have done this as well and still unable to get it going. Any suggestions?

Thanks in advance.


#2

You need to check your ovpn file, there are some lines e.g. “ca ca.crt”, indicating ca file is ca.crt
Although you have put these files in the same folder, but if the name is not correct, the router will report that it cannot find the correct file.


#3

I am having the same problem. I have unzipped the file from untangle and moved everything into a single folder, edited the .config and .ovpn files to update the filenames for the crt, key, and -ca.crt files, and then zipped it back up.

I get the same error when I try to upload it to the OpenVPN page.

 


#4

Do you installed untangle by yourself to your own server? I just checked untangle website and this is still not very clear how it works.

Is it possible that you send a sample config zip and I can have a check.


#5

.


#6

Thank you for the input alzhao,

I have attached the config file generated by untangle. Due to this being a public forum, I’ve altered the server details and certificates.

I appreciate the help.


#7

Did you ever end up getting this to work with Untangle? I am having similar problem using the latest firmware for the MT-300N V2. I tried the zip file and the single file with the certificates inline. The later imports fine but cannot connect. The zip uploads but asks for a passphrase?


#8

It seems there have a untangle firmware, not sure how does it work. If you can send me your OpenVPN configuration files with certificate, I can have a check.