connecting to a hotel wifi (MT300A sees it as a hidden ssid?)

Hello,

I recently got a GL-MT300A. I updated it to firmware 2.25. Its great by the way :slight_smile: I got it specifically to replace another travel router because of its openVPN features. My most common use will be connecting to wifi networks and using openVPN to secure my connection. For the first network I tried, everything worked perfectly. It was easy to use the GUI set up both the WISP repeater and the open VPN client. I am currently on the road and ran into a problem.

I am in a hotel that has free wifi, the kind you have to sign in via the web the first time you connect. It is IHG, a major chain of hotels, so probably not an uncommon setup. On all my devices (computer, tablet, phone), it shows up as an unsecured wifi. It is not MAC filtered. When I use the MT300A however, the wifi does not show up in the new connection repeater GUI. If I use the advanced settings (LuCI), I think I can see the network. What I see in LuCI is a series of hidden networks (6 or 7 total on channels 1, 6, and 11). I am assuming that these are the hotel network (mesh, all with the same SSID). My question is, why does this show up on all my devises with an SSID name (IHGConnect), but it is seen by the MT300A as a bunch of hidden networks? Is there a way to see these networks in the Repeater Manager GUI? If not, what is the procedure to replicate the same thing in LuCI or manually?

Thanks for the help!

If it is on a channel above 11, then it won’t show in the router as the Wireless default is US (1-11).

In Luci:

Network>WiFi>Edit>Advanced>Country Code> change to GB.

Glitch

Thanks for the reply. None of the channels were above 11, and I am in the US.

Hi I am not sure why it shows hidden.

But you can do this: set as repeater first in a know wifi network. Then if you go to the hotel, this repeater will be disabled because the router cannot find the network. But in Luci, you can edit it. Just go to luci and edit it, you will be able to edit ssid, encryption etc. Modify it as the hotel wifi. Then enable and connect and check if you can connect to it.

Update:

Still not sure why it shows up as hidden. It still shows up normally on my computer (Win), tablet (android), and phone (android). I did check with another travel router I have (HooToo TripMate Nano). Interestingly, the wifi also does not show up on it for possible bridge/repeater connection on the TripMate Nano.

I tried you suggestion, but I don’t think I know enough to do it. I already had a single saved station that I knew worked. It is a WPA2 secured wifi with the SSID broadcast. I wanted to keep that one as I will use it again later. I therefore set up a temporary wifi to connect to and set as another repeater. I used the repeater GUI to create the connection. Unfortunately, when I went in to LuCI, I couldn’t edit the saved connection. In LuCI, there is a interface called (WWAN) that seems to be where the repeater connection is made. It seemed to be named and setup as the first saved connection that I wanted to keep. I couldn’t find anything that matched the second saved connection that I wanted to use to edit. Can you explain how I can edit the settings from the second saved connection in LuCI? (or how to just set it up in LuCI?) Is there any normal way to set up a repeater/bridge with a hidden network?

@kawayanan,

In luci, you need to go Network->wifi, not network->interfaces

 

I’m struggling with the same issue at work. I can’t see the SSID of a given network. I do have my home network, which shows under “Saved Connections”. It is, of course, unavailable as I’m not currently home.

I’ve gone into Luci, selected Network…Wireless and then edited the existing Wireless Client shown (the one that is NOT the WLAN created by my Mango device) to the new SSID.

As soon as that change is made, I can no longer connect and have to reset the router to factory defaults.

Here is the guide of connecting to a hidden network.

First, you need to know if your Hidden WiFi network is 2.4G or 5G.
Then you have need to connect to an existing non-hidden SSID first. This step is set up everything for you.

After you have done this, do the following:

  1. Advanced settings (luci) -> Network -> wifi,
    Find your current client, click Edit

  1. Input your hidden SSID info.
    image

image

  1. Finally, click save & apply

If you use the Mango, please don’t configure wireless related in luci as it uses closed wireless driver. Besides, if there are more than 34 APs in your environment, and the your upstream AP is high channel, it might cannot scan it.

Alzhao’s instructions don’t, of course, look the same on my Mango. So going along with what you’re saying, I don’t have 34 APs, so how do I go about fixing this?

I can scan and identify this SSID through every other method / device I’ve tried EXCEPT for the Mango which AT BEST shows it as a blank SSID with no name. But attempting to connect to those does not work (or at least it’s not the one I’m looking for).

Thanks, but the interface on my Mango is totally different. And while I can change the SSID via Luci, I cannot, for example, seem to change the Channel, etc., nor can I select WPA2 as the encryption type.

Maybe there is a long SSID in your environment. Could you please upgrade to the testing firmware and try again? You can download it from the link. Please don’t ticked “keep settings” when upgrading.

I tried this with the same result (although the interface is very nice). I still don’t have an option to change frequencies, select WPA2, etc. under advanced settings.

That’s it, then? This router doesn’t work with hidden SSIDs?

Let’s say this, if you cannot configure using advanced settings then it is a NO.

Popping in to say that I would also require this feature. Please do consider adding it to the routers firmware.

Thanks,

Connecting to hidden network has been added. This thread is 2 years old.

Choose “other” in the wifi list and you can type ssid manually.

1 Like