Custom DNS not working when VPN policy is based on VLAN

As the title says, custom DNS not working when VPN policy is based on VLAN.

In my case I enabled the VPN only for the guest network. On my private network I use NextDNS as dns filter.

Having enabled VPN for guest network, the DNS set for the private VLAN gets ignored. No matter what it’s changed too.

Currently running the latest beta firmware for the Flint-AX1800.

~ Edit: The VPN doesn’t even have to be enabled for custom DNS to be ignored. As soon as the VLAN Policy is selected, the custom DNS gets ignored

It is a bug I think.

I submited bug report internally.

1 Like