Custom Exit Node of Tailscale not working

I have bought 2 GL-iNet routers to use Tailscale.

GL-AX1800 (Flint) v4.4.6, the home router
I’ve set it up to work as the exit node, I had to edit the config file via SSH to allow it to be used as the exit node. When I use Tailscale from my phone and set this router as the exit node, I can navigate, and access my home network, and of course, the IP is the same as my home.

GL-MT3000 (Beryl) v4.4.6, the travel router
I’ve connected it to Tailscale, but when I set my home router as the exit node, I don’t have access to the internet at all.

What am I doing wrong with the configuration of the Beryl?

Using Custom Exit Node.zip (631.7 KB)
hi,
please refer to the attached user guide.

hi @fangzekun for the quick reply, I followed your instructions, I was able to apply all the steps up to the 4th.

Following the 5th step, when I run tailscale status -json, the node of the MT3000 is not listed in the Peer object, but I can see the exit node (the GL-AX1800) and another device. When I look into the Self object, there is no PrimaryRoutes key for the MT3000.

hi,
Did you setup AX1800 as Exit node? Have you added “–accept-routes” option when run “tailscale up” on exit node?

Yes I did set up AX1800 as an exit node and it works, I’ve tested it from my phone where I installed Tailscale and set up the AX1800 as the exit node.

Side notes, I’m using the tethering connection on the MT3000 with my iPhone connected with the cable, in order to test it on 2 networks.

Did you setup AX1800 by running “tailscale up --advertise-exit-node”?please run following commands on AX1800 to accept routes.
sed -i 's@/usr/sbin/tailscale up --reset --accept-routes $param --timeout 3s > /dev/null@/usr/sbin/tailscale up --reset --advertise-exit-node --accept-routes $param --timeout 3s > /dev/null@' /usr/bin/gl_tailscale

/usr/bin/gl_tailscale restart

I already did set up the AX1800 as exit node, just double checked and this is a screenshot of it:

I’ve then run the restart command /usr/bin/gl_tailscale restart, I’ve also enabled all the subnets in tailscale on both routers.

But still no luck

hi,
I have PM you a document on how to share device.Please share both MT3000 and AX1800 with me, and PM me the MAC address and your router’s login password for remote check.Thanks!