Custom Subnet on GL-SFT1200

Hey all!

Im running a GL-SFT200 Router running firmware version 3.216. We use this router as an access point on the go to provide internet to our devices when working in remote locations. These are typically tower sites, radio sites, etc, which have ethernet connectivity but no WiFi. Typically, these networks are on 10.1.1 or 172.75.2 or other random non-192.168 subnets.

So far I am able to get internet access to these devices by configuring the network to match the subnet. However, we are unable to access any other devices on the network because it still hands out 192.168.1.* IP addresses to the devices that connect to it.

When I go in to System -> LAN and look to change the IP address it uses and hands out, it only lets me change the last two parts and forces me to use 192.168...

I need to set this to, for example, for the router and the start IP to and end to

How do I do this?

Same issue on the latest Opal 4.3.11 firmware, not allowed to change the first two octets of the LAN subnet.

It's possible to do this in Luci, but GL.iNet need to advise why this is hardcoded.

I was able to change it in the web config page after I updated the firmware. The option is not present in the app.

However, I still could not access devices on the host LAN until I unplugged the ethernet from the WAN port and plugged it into the LAN port.

Then, I was able to access the LAN devices but couldnt access the general internet, since the gateway was wrong.

To fix this, I had to manually set the gateway IP on each connected device to the IP of the host router.

This would be resolved if the router had an access point mode built in, which is how I expect most people to be using this router in the first place if it really is a "Travel" router, or if I could at least set the gateway IP it assigns to devices to something other than itself.

You need to adjust the DHCP server as well.

It totally has. See Network Mode - GL.iNet Router Docs 4

No, people mostly use the full routing mode because you want to get the additional security by using this.

Gotchya. The Network mode section was in a different area on my router, under "More Advanced Settings" which threw me off.

It's odd, when I set it to Access point mode I cant access anything on the LAN or the internet. It just drops out. When in router mode, it works fine. When in access mode, does it still use the settings under the "Internet" tab, such as the static IP, gateway, and dns settings? DHCP is not enabled on any of the networks we use for obvious reasons.

Sadly it looks like Access Point mode doesnt support static IP addresses, making it unusable on networks not using DHCP...


I started a new question specifically asking on this in case it needs to be a feature request.

You can always use luci or SSH to configure the network as you like.

I was unaware open-wrt config was built in. I'll see if I can find an easy way to configure this on the go and will report back if I find anything.