DDNS names not resolving but IP address will work on WireGuard client

Is there an issue with the Wire Guard client were its not resolving any DDNS addresses. I am able to directly connect with Wire Guard with my IP address, but not when using its DDNS address. Any help to resolved this will help. Thanks

Double-check that the WireGuard config file has the correct DDNS domain name as endpoint.

If you have a PC or Mac client device, then try opening a command prompt/terminal window to run nslookup, which should have the same result as the public IP address:

nslookup (DDNS domain name)

I do not work for and I am not directly associated with GL.iNet

My DDNS works fine with all my devices that is also using wire guard and many other items that uses the DDNS that I am using (I also reconfirmed that the DDNS address did work with all my devices before trying it on this)…its just with(should have mentioned the device I am using) GL-AXT1800, Slate AX, with the latest sofware its seems not connceting…

What is the DNS server used by the GL-AXT1800? Can you test setting the Manual DNS to or

You can also SSH into the GL-AXT1800 and run the same nslookup command to confirm the DDNS domain name is resolved on the router. If it is, then check/post the System Log that may have error messages when the WireGuard client starts up.

It should work with ddns.

You can dm me your ddns and wireguard config to have a check?

Ok…I guess I missed setting up manually the DNS’s on the GL-AXT1800, once I set the DNS’s to it finally worked for me. Thanks anyway for your assistance with this matter

1 Like