Debug connection failed on glinet as repeater


#1

On my gl inet I have set up WISD to act as a repeater. Frequently it does not manage to connect to the network and I don’t know why. I reset the router (firstboot) and it starts working again.
How can I debug these failed attempts? I click connect on the web interface, but nothing happens.

/etc/config/dhcp:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/qca953x_wmac'
	option hwmode '11ng'
	option htmode 'HT40+'
	option noscan '1'
	option txpower '20'
	option channel '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk-mixed'
	option wds '1'
	option ifname 'wlan0'
	option isolate '1'
	option ssid 'gl inet ssid'
	option key 'gl inet pw'

config wifi-iface 'sta'
	option device 'radio0'
	option ifname 'wlan-sta'
	option network 'wwan'
	option mode 'sta'
	option key 'key'
	option bssid 'bssid'
	option ssid 'ssid to connect to'
	option encryption 'psk-mixed'

/etc/config/firewall and /etc/config/network if needed are here: Icmp port unreachable
Log level is 1 and nothing useful is in logread. The firmware is 2.27. I might return the product if I can’t connect it


#2

Why don’t you use the admin web page to connect it?


#3

I’m using the web interface to connect it. It just doesn’t want to.


#4

I suggest that you get some log otherwise cannot determine the problem.

Can you try firmware v3.x? What is you model? AR300M?


#5

Ok, what logs should I get?
It’s an GL-AR300M16. I can try the 3.x, but I thought the stable / recommended version was the 2.7


#6

ssh to the router and

logread